Reply
 
Thread Tools Display Modes
Old 01-02-2011, 03:24 PM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 5
12 volts not working except from tow vehicle

rockwood roo travel trailer: 12 volt sytem not working from battery but works when plugged into the truck. The battery has been checked for voltatge and load tested. The system also works on land power If there is a master 12 volt switch or inline fuse I sure can't find it
__________________

__________________
ericmace is offline   Reply With Quote
Old 01-02-2011, 03:45 PM   #2
Senior Member
 
Join Date: Aug 2010
Posts: 855
There is probably a battery disconnect switch. There will also be an inline circuit breaker. When you find it, look for a really small button on the bottom and press it in to reset.
__________________

__________________
donn is offline   Reply With Quote
Old 01-02-2011, 03:47 PM   #3
Senior Member
 
jimh's Avatar
 
Join Date: Jul 2010
Location: Lake Charles, La.
Posts: 1,531
check the battery disconnect. mine is located as i enter my 5th wheel above the breaker box.
__________________
jimh is offline   Reply With Quote
Old 01-02-2011, 03:48 PM   #4
Junior Member
 
Join Date: Jan 2011
Posts: 5
are those items generally in the inverter?
__________________
ericmace is offline   Reply With Quote
Old 01-02-2011, 03:50 PM   #5
Junior Member
 
Join Date: Jan 2011
Posts: 5
seems odd that it would work off of the truck batttery if it was a master 12 volt switch (which I can not fiind if there is one
__________________
ericmace is offline   Reply With Quote
Old 01-02-2011, 04:01 PM   #6
Senior Member
 
jimh's Avatar
 
Join Date: Jul 2010
Location: Lake Charles, La.
Posts: 1,531
Quote:
Originally Posted by ericmace View Post
seems odd that it would work off of the truck batttery if it was a master 12 volt switch (which I can not fiind if there is one
i believe it will only work on the converter when the disconnect is thrown. i haven't tried it though.

the disconnect on mine (2002 cardnal) is a red lever looking key...i think it has a chain on it.
__________________
jimh is offline   Reply With Quote
Old 01-02-2011, 04:04 PM   #7
Senior Member
 
jimh's Avatar
 
Join Date: Jul 2010
Location: Lake Charles, La.
Posts: 1,531
nope, i misread it. the master disconnects everything but the converter. if it working on the truck, sounds like a circuit breaker. follow the wires back from the bat. they like to hide them.
__________________
jimh is offline   Reply With Quote
Old 01-02-2011, 04:07 PM   #8
Junior Member
 
Join Date: Jan 2011
Posts: 5
good to know they like to hide the switch, I will keep looking along the route of the wires
__________________
ericmace is offline   Reply With Quote
Old 01-02-2011, 04:30 PM   #9
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,241
you might want to post this in the Roo section under Expandables.

first, Roos don't come with a battery disconnect switch unless the dealer or previous owner installed one.

the most common reason, on Roos, for this is the inline circuit breaker switch from the battery back to the trailer. i believe it's inside the tongue frame. you can reset it. happens alot when owners hook up the battery wrong.

and you don't have an inverter, you have converter. unless someone installed one and it wouldn't have anything to do with no 12v power.
__________________
bikendan is online now   Reply With Quote
Old 01-03-2011, 07:57 AM   #10
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,154
Please let us know when you find the source of your problem. We love hearing whether we were able to help you solve your issue.

My 2 cents: I had a similar problem with my 5th wheel after only 9 months of use. It was a corroded terminal connector on the red wires where the converter, tow vehicle charging line, and the battery come together. The terminal was corroded by water and salt spray. 5 minutes with a wire brush, a coat of dielectric grease, and I was back in business. It was not at all apparent looking at it from the "outside." I took the nut off and it was obvious that the terminals had lost contact with each other.
__________________

__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Reply

Tags
12 volt

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:34 AM.