Reply
 
Thread Tools Display Modes
Old 09-04-2010, 12:05 PM   #1
Junior Member
 
Join Date: Aug 2010
Posts: 6
2004 forest river surveyor- sos

re: attwood hydro flame furnance

can't figure out how to turn it on. there is a knob/tab that says off.

looks like it's stuck in the 'off' position...any ideas?
__________________

__________________
traveler is offline   Reply With Quote
Old 09-04-2010, 01:03 PM   #2
Senior Member
 
NWJeeper's Avatar
 
Join Date: Aug 2008
Location: Enumclaw, WA
Posts: 2,617
Hmm, haven't had experience with Attwood furnaces, only suburban. Are you talking about a switch on the thermostat or the furnace itself?
__________________

__________________
"I can fix it, and if I can't fix it, I can fix it so no one can fix it!"
Ed & Wendy
2009 Georgetown 378TS | 1998 Jeep Wrangler | 1998 Skeeter ZX202C
Nights camped in 2009: 53 | Nights camped in 2010: 55
www.nwjeepn.com
NWJeeper is offline   Reply With Quote
Old 09-04-2010, 01:11 PM   #3
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,360
Quote:
Originally Posted by traveler View Post
re: attwood hydro flame furnance

can't figure out how to turn it on. there is a knob/tab that says off.

looks like it's stuck in the 'off' position...any ideas?
What is stuck in the off position? The thermostat controls?
If youare unable to move the slide from OFF to AC or Heat you probably need the thermostat replaced or have someone that know a little about trailers take a look.

First pic is my thermostat. Does yours look similiar?
or like the second picture?

If not can you take a picture of the unit or give us the model number of heater?


Did you ever find your water pump from your earlier tread?
Attached Thumbnails
Click image for larger version

Name:	thermostat.JPG
Views:	83
Size:	37.5 KB
ID:	3344   Click image for larger version

Name:	thermostat2.jpg
Views:	80
Size:	15.3 KB
ID:	3345  
__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Old 09-04-2010, 02:54 PM   #4
Junior Member
 
Join Date: Aug 2010
Posts: 6
atwood thermostat/furnace - water pump reply

Thanks, NWJeeper and Iggy...
all indications are it's the thermostat. it's in the on positon outside but won't trigger inside. one of the coldest labor day yet. thank goodness for sleeping bags
as for the water pump. all set. replaced a couple of weeks again. ready to go.
what a great website! happy labor day to all.
__________________
traveler is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:49 PM.