Thread Tools Display Modes
Old 05-25-2011, 08:15 AM   #1
Junior Member
Join Date: Apr 2011
Posts: 10
2004 LE 24BHSS AC problem

I am prepping for a weekend trip (first of the year). I cranked up the 2 Honda 2000's (parallel) and plugged into the campanion 30a outlet (eco off). All seems fine.

When I turn on the fan I hear a click and slight hum. The generators ramp up slightly. When I turn on the AC I get a click and slight hum. Again, the generators ramp up slightly. I have checked each fuse with a tester. All other appliances are turned off.

I beleive the unit is a Duo-Therm (Dometic) 13,000 btu. The only paperwork that I have is waranty sheet.

We purchased this last summer and used the AC 2 times and it worked fine.

Any ideas?

Thanks Much!
msula95 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:09 AM.