Reply
 
Thread Tools Display Modes
Old 12-23-2012, 11:33 AM   #1
Junior Member
 
Join Date: Jun 2012
Posts: 4
2006 Flagstaff Forest River Pop Up- Overhead lights turning OFF

Any idea why our overhead lights on our 2006 Pop Up are turning OFF after being ON for a while? Last nigth they were ON for a few hours and all of the sudden went OFF. We check the breakers/fuses and semm to be OK.
We lowered the sink for a while and back up again and one side aft came On. When we turned the Fwd ones, then the whole thing OFF again.
All electrical connections are plugged in so no idea why is doing this.

Anybody give us idea why the lights are going OFF?


Thanks and Merry Christmas....
__________________

__________________
flagstaff2006 is offline   Reply With Quote
Old 12-24-2012, 07:04 PM   #2
CampingQueen
 
Join Date: Aug 2012
Posts: 199
Do you have the 'master' switch on your popup? Maybe there is a short in that switch? Not sure, but giving your post a 'bump' to see if anyone else has any ideas...
__________________

__________________
2012 Flagstaff V-lite 30 WTBS
2011 Ford Expedition
4 kids and a hubby & never enough time to camp!
2011: 17 nights 2012: 26 nights 2013: 46 2014: 20 2015: 16
arlee453 is offline   Reply With Quote
Old 12-24-2012, 07:32 PM   #3
Senior Member
 
Twisty's Avatar
 
Join Date: Mar 2012
Posts: 1,138
Lower the sink and operate the switch by hand. Inconsistent results = bad switch or loose/bad ground.
__________________
FOR SALE 2014 BOSS 6.2L F350
2012 Surveyor SV264
NW Oregon
Twisty is offline   Reply With Quote
Old 12-24-2012, 07:53 PM   #4
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by flagstaff2006
Any idea why our overhead lights on our 2006 Pop Up are turning OFF after being ON for a while? Last nigth they were ON for a few hours and all of the sudden went OFF. We check the breakers/fuses and semm to be OK.
We lowered the sink for a while and back up again and one side aft came On. When we turned the Fwd ones, then the whole thing OFF again.
All electrical connections are plugged in so no idea why is doing this.

Anybody give us idea why the lights are going OFF?

Thanks and Merry Christmas....
Sounds like the saftey switch, in the hinged cab is burned or defective. When lights are on for awile, contact warms up and opens. Same as turning on 2nd light. You can try to temp jump out the switch, or just change it. Another cause can be poor battery connection or ground connection at the frame. Disconnect and clean all, should help.
__________________
VinceU is offline   Reply With Quote
Old 12-26-2012, 08:38 AM   #5
Junior Member
 
Join Date: Jun 2012
Posts: 4
Smile Thanks for all the ideas, i'm going to troubleshoot the problem today, hope it works.

Ill let you know if i get the lights to stay On....

Thanks so much..
__________________
flagstaff2006 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:00 PM.