Reply
 
Thread Tools Display Modes
Old 06-05-2011, 05:25 PM   #1
Junior Member
 
Join Date: Jun 2011
Posts: 6
2007 Sunseeker microwave power loss

I am a new MH owner, just bought this 2007 from an older couple. We have been camping for a little over a week, learning the ins and outs of this vehicle, really enjoying it! We have used the microwave several times, with no issues, but today, tried to do regular rice - requires a 15 minute cook time at 50% power after boiling. Almost to the end of the cook time, the unit simply shut off. I have yet to find/figure out the power converter "stuff", but... what troubleshooting would you do? fridge still works, lights are still on, outlets still work, it has been several hours since this happened. Did I fry the microwave???

Any help, thanks so much!

jen
(I was trying to conserve propane, hence the rice in the microwave)
__________________

__________________
musicjen is offline   Reply With Quote
Old 06-05-2011, 06:49 PM   #2
Senior Member
 
jaxfl's Avatar
 
Join Date: Sep 2008
Location: jacksonville fl
Posts: 319
You might check the breakers you might have popped one. My 1st thought.
__________________

__________________
jaxfl is offline   Reply With Quote
Old 06-05-2011, 07:19 PM   #3
Junior Member
 
Join Date: Jun 2011
Posts: 6
Yes, but I don't know where they might be...
__________________
musicjen is offline   Reply With Quote
Old 06-05-2011, 08:14 PM   #4
Senior Member
 
jaxfl's Avatar
 
Join Date: Sep 2008
Location: jacksonville fl
Posts: 319
On the 2008 it is on the wall under the bed. A dark cover, open it and you will see switchs and fuses. Hope that helps.
__________________
jaxfl is offline   Reply With Quote
Old 06-05-2011, 08:22 PM   #5
Junior Member
 
Join Date: Jun 2011
Posts: 6
Woohoo!!! Thanks!

Of course, no circuits were tripped or fuses blown, so does that mean I fried it?
__________________
musicjen is offline   Reply With Quote
Old 06-05-2011, 10:31 PM   #6
Senior Member
 
jimh's Avatar
 
Join Date: Jul 2010
Location: Lake Charles, La.
Posts: 1,531
not necessarily. i'm going to assume u shut the breaker off to the microwave and reset it. sometimes "trip" is so close to "on" the breaker could appear to be set.
next, i would try running an extension from another outlet just to see if it comes on. if it doesn't, there is a fuse inside the microwave. u will have to take it out of its case to find and it is probably ceramic.
lets hope it is a breaker not set.
__________________
jimh is offline   Reply With Quote
Old 06-05-2011, 11:32 PM   #7
Junior Member
 
Join Date: Jun 2011
Posts: 6
Thanks Jim, especially for assuming I turned the breaker off and on - I honestly mean it. I did not, so will try that, and your other suggestions if necessary.
Really grateful for all the help.
jen
__________________

__________________
musicjen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:28 AM.