Reply
 
Thread Tools Display Modes
Old 08-26-2015, 07:33 PM   #1
Junior Member
 
Join Date: Jul 2015
Posts: 26
Question 2015 FR3170ds Water smell

This will be my second time out since i purchased my FR Sunseeker 3170 ds. The first time was a quick trip to get familiar with our new home away from home. Here is my problem the hot water has a sulfur smell. I figured the system needed to be flushed. I have flushed the system (no chemicals) When i heat the hot water up the smell seems to disappear. When the hot water cools down (runs out ) the smell comes back. Does anyone out there know how to solve my smelly problem? Thank you to all and travel safely.
__________________

__________________
Wilber2484 is offline   Reply With Quote
Old 08-26-2015, 09:51 PM   #2
Member
 
Join Date: Sep 2013
Posts: 60
You have algae growing in the hot water tank causing the rotten egg smell. This commonly occurs when the water sits in the hot water tank and not cycled for long periods of time (baking in the sun). It's easy to correct. Just sanitize your water lines. Follow the instructions in your manual. I believe it's 1/4 cup of bleach for every 10 gallons of water in your fresh water tank. After filling the fresh water tank, run the hot water for a while to fill it with the chlorinated water. Run the cold water until you start smelling bleach. Do this at all faucets. Let it sit for three hours (or overnight) then drain the tanks and run fresh water through the system until you no longer smell bleach. All done. The rotten egg smell will be gone.

If you are going to leave the trailer sitting for long periods, I'd suggest draining the water tank. It's a pain, but it's prevented me from having reoccurring rotten egg smells.

Hope this helps.


Sent from my iPhone using Forest River Forums
__________________

__________________
2914 Tracer 2950BHS
Griswalds is offline   Reply With Quote
Old 08-27-2015, 09:03 AM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Griswalds View Post
You have algae growing in the hot water tank causing the rotten egg smell. This commonly occurs when the water sits in the hot water tank and not cycled for long periods of time (baking in the sun). It's easy to correct. Just sanitize your water lines. Follow the instructions in your manual. I believe it's 1/4 cup of bleach for every 10 gallons of water in your fresh water tank. After filling the fresh water tank, run the hot water for a while to fill it with the chlorinated water. Run the cold water until you start smelling bleach. Do this at all faucets. Let it sit for three hours (or overnight) then drain the tanks and run fresh water through the system until you no longer smell bleach. All done. The rotten egg smell will be gone.

If you are going to leave the trailer sitting for long periods, I'd suggest draining the water tank. It's a pain, but it's prevented me from having reoccurring rotten egg smells.

Hope this helps.


Sent from my iPhone using Forest River Forums
X2

TURBS
08 duramax tuned n modded
2011 32bhok Sabre
2015 camping "24 nights"
__________________
TURBS is offline   Reply With Quote
Reply

Tags
3170, water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:45 PM.