Reply
 
Thread Tools Display Modes
Old 06-22-2015, 03:26 PM   #1
Junior Member
 
Join Date: Jun 2015
Posts: 5
2015 Sandstorm fuel station not working.

went to use the fuel station for the first time and it was a no go. Here is the problem.
Put 20 gal,in tank
Turned on fuel system and every thing lights up so far so good
The tank still reads empty not good
The pump does not come on getting worse.
Try the shut off switch both ways still a no go
Reset the timer and check the switch and pump for power. The kids are getting upset by now because the atv are out of gas.
Still not working.
Had to jump out the pump to get it to run to fill up the toys
What do i need to check next. could the timer be bad?
__________________

__________________
jeepinalabama is offline   Reply With Quote
Old 06-25-2015, 04:40 PM   #2
Senior Member
 
Join Date: Apr 2015
Posts: 115
Check for power at the switch first. If no power there, then work backwards from there. If there is power at the switch, then check for power at the pump. If no power at the pump, then look between the switch and the pump. If there is power at the pump, check the pump itself.
__________________

__________________
slapshot12 is offline   Reply With Quote
Old 06-25-2015, 04:56 PM   #3
Junior Member
 
Join Date: Jun 2015
Posts: 5
There is no power to the switch.
No power to the sending unit.
So there has to be a problem at the control panel.
When i called the dealer they said that they would get right back to me. That was 2 days ago. then they said they could get me in on the 22 of July. I bought this new in April. Now they want me to wait until then before i bring it in.
__________________
jeepinalabama is offline   Reply With Quote
Old 06-25-2015, 05:22 PM   #4
Senior Member
 
Join Date: Apr 2015
Posts: 115
I'd work backwards from the switch until you find power. It may be a pain tracing wires, but that's the easiest way. My bet is something was either hooked up wrong, or not at all. You may check to see if you have a breaker for the gas station, or a blown fuse somewhere along the line.
__________________
slapshot12 is offline   Reply With Quote
Old 06-25-2015, 05:40 PM   #5
Junior Member
 
Join Date: Jun 2015
Posts: 5
I know the fuse is good when i take it out i loose power to the control panel and fuel gauge. Forest River just dont give ya any info on this system. Thanks for the reply Ill start back tracking... I guess i could always run a power wire to the E switch by the pump and just use it and not the switch inside. I just hate to do that after spending the 28 grand.
__________________
jeepinalabama is offline   Reply With Quote
Old 06-26-2015, 04:35 PM   #6
Senior Member
 
Join Date: Apr 2015
Posts: 115
I know the feeling, I had a couple issues too and it's annoying. Even more annoying is leaving the trailer at the dealer for god knows how long for a simple warranty repair. I'm at 2 months and counting on 3 screws and the upper gas tube mount on my entry door.

If you power to the control panel, then I'd look between there and the switch and start back tracking. I don't know who they're wired either, so I can't offer more details.
__________________

__________________
slapshot12 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:53 PM.