Reply
 
Thread Tools Display Modes
Old 06-02-2011, 09:27 PM   #21
Senior Member
 
M109Rrider's Avatar
 
Join Date: Oct 2010
Location: Chesapeake, Va
Posts: 877
I'm curious, keep us posted. I haven't used my a/c yet either. I do know it blows hard though
__________________

__________________

Jason and Billie
2005 Dodge Ram 2500, 4X4, QC/SB 5.9L Cummins
15k non-sliding Hidden Hitch (they lied, it's not hidden at all)
2011 Prime Time Crusader 320RLT
"PT Crew Member Since 11/2010"
M109Rrider is offline   Reply With Quote
Old 06-16-2011, 07:00 PM   #22
2011 Crusader 320RLT
 
Join Date: Mar 2011
Posts: 20
ok. We got it back from the repair shop. The manufacturer forgot to cut the holes from the unit to the trailer through the insulation. So, it is running good now and blowing plenty of air. Also, the valve was partially turned to the water heater letting cold water bleed into the water flow, so it felt like our hot water was not getting hot. Hopefully all is fixed now. Thanks for all the help from everyone!
__________________

__________________
lilspiritus is offline   Reply With Quote
Old 06-16-2011, 07:20 PM   #23
Commercial Member
 
Join Date: Jan 2011
Posts: 580
lilspirtus - sorry about the issue you had. Would you mind telling us who your dealer is so we can call them and get more info?

Thanks for your business.

PTM
__________________
RV Guy is offline   Reply With Quote
Old 06-16-2011, 07:49 PM   #24
Senior Member
 
BOBFIDY's Avatar
 
Join Date: Sep 2010
Location: Broken Arrow, OK
Posts: 1,110
Quote:
Originally Posted by lilspiritus View Post
ok. We got it back from the repair shop. The manufacturer forgot to cut the holes from the unit to the trailer through the insulation. So, it is running good now and blowing plenty of air. Also, the valve was partially turned to the water heater letting cold water bleed into the water flow, so it felt like our hot water was not getting hot. Hopefully all is fixed now. Thanks for all the help from everyone!
WOW.....I'll bet we ALL could have kept guess FOREVER and not come with "THEY FORGOT TO CUT THE HOLE".....Wonder how often that happens???
__________________
2011 FORD F350 CREW CAB DUALLY DIESEL 4x2
2010 Salem LA 292FKDS
One of the Original 14 F.R.O.G.s
1st, 2nd, and 3rd INTERNATIONAL F.R.O.G. RALLY Branson. MO.
1st, 2nd, and 4th INTERNATIONAL RALLY Goshen, IN.
BOBFIDY is offline   Reply With Quote
Old 06-16-2011, 09:34 PM   #25
2011 Crusader 320RLT
 
Join Date: Mar 2011
Posts: 20
We bought it from Tom Raper RV in Richmond, Indiana. The people who repaired it was Indy RV service in Indianapolis, IN. We didnt want to take it all the way back to Richmond, so they recommended we take it to Indy.
__________________
lilspiritus is offline   Reply With Quote
Old 06-16-2011, 11:34 PM   #26
Senior Member
 
M109Rrider's Avatar
 
Join Date: Oct 2010
Location: Chesapeake, Va
Posts: 877
Quote:
Originally Posted by BOBFIDY View Post
WOW.....I'll bet we ALL could have kept guess FOREVER and not come with "THEY FORGOT TO CUT THE HOLE".....Wonder how often that happens???
See post #12
__________________

__________________

Jason and Billie
2005 Dodge Ram 2500, 4X4, QC/SB 5.9L Cummins
15k non-sliding Hidden Hitch (they lied, it's not hidden at all)
2011 Prime Time Crusader 320RLT
"PT Crew Member Since 11/2010"
M109Rrider is offline   Reply With Quote
Reply

Tags
air conditioner

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:07 PM.