Reply
 
Thread Tools Display Modes
Old 05-29-2011, 05:25 PM   #1
2011 Crusader 320RLT
 
Join Date: Mar 2011
Posts: 20
2011 crusader, ac runs but dont blow air-help!

This is our first trip out with our new 2011 32 ft crusader. The ac turns on but does not blow air... can anyone help? Is there something to check?
__________________

__________________
lilspiritus is offline   Reply With Quote
Old 05-29-2011, 05:43 PM   #2
Senior Member
 
BOBFIDY's Avatar
 
Join Date: Sep 2010
Location: Broken Arrow, OK
Posts: 1,002
Stupid question to your question...but...is the vent/grid open to let air out?
Is there air going to the rest of the rig? Or maybe your rig does not have vented A/C.
Trying to help you with helped us.
__________________

__________________
2011 FORD F350 CREW CAB DUALLY DIESEL 4x2
2010 Salem LA 292FKDS
One of the Original 14 F.R.O.G.s
1st INTERNATIONAL F.R.O.G. RALLY Branson. MO.
2nd and 3rd INTERNATIONAL RALLY Goshen, IN.
BOBFIDY is offline   Reply With Quote
Old 05-29-2011, 05:51 PM   #3
2011 Crusader 320RLT
 
Join Date: Mar 2011
Posts: 20
BOBFIDY.. not a stupid question.. where is it? It is brand new, and I havent checked, but that is what I asked my husband. Where would we open the vent/grid? It is a 2011 Crusader fifth wheel.
The dealer had not opened the valves to let water go to the water heater either, so I am not surprised if this isnt open either. Thank you for helping. We had an outback before. Never had these kinds of issues on a new trailer before. The outback was ready to roll - We are supposed to leave tomorrow, but - we will see now!
__________________
lilspiritus is offline   Reply With Quote
Old 05-29-2011, 05:55 PM   #4
2011 Crusader 320RLT
 
Join Date: Mar 2011
Posts: 20
It is a central ac unit on top (not inside) the unit. Air vents have been turned, no air.
__________________
lilspiritus is offline   Reply With Quote
Old 05-29-2011, 06:25 PM   #5
2011 Crusader 320RLT
 
Join Date: Mar 2011
Posts: 20
Air Conditioning running but no air from vents

We have a 2011 Crusader. We can hear the ac running, but no air coming from vents. Even with the thermostat set to vent, no air. Vents do not close, just directional. Any other suggestions? First time going out,.. figures it would be on a holiday weekend with no open dealerships.
__________________
lilspiritus is offline   Reply With Quote
Old 05-29-2011, 07:22 PM   #6
Senior Member
 
grhodes50's Avatar
 
Join Date: Dec 2007
Location: Eastern Oklahoma, USA
Posts: 2,450
On the AC itself there is a vent. If it's open it will cut the air flow to your other vents.

Let me rephrase that. It won't cut the air flow to your ceiling vents, but it will allow enough volume of air to come out at the AC vent itself that little or no air will reach the ceiling vents. It's what they call the Quick Cool feature.
I'm not sure if this is your problem or not, but you might check to see.
__________________

Gary & Trish
"PT Crew Member Since 11/2010"
2011 LaCrosse 303 RKS Touring Edition : 2007 Flagstaff 206ST MAC Series
2012 F-250 Lariat : FX4 : CC : SB : 6.7L Diesel : 3/55 Gears

2014 Nights Camped - 3
grhodes50 is offline   Reply With Quote
Old 05-29-2011, 10:16 PM   #7
Moderator Emeritus
 
Join Date: Nov 2008
Location: Winston-Salem, NC
Posts: 2,381
You didn't say what model your air was, but since you mentioned vents don't close, I will ASSUME a non ducted AC. Take the cover off from inside, two one quarter-turn screws on one end, on most models. Now turn on the AC. Do you feel air moving? Should be blowing straight down. If not you may have a fan problem. You might be able to see the fan to tell if it is running. If no fan, then need to continue, but verify the fan is running first. (you mentioned you hear it running, but you may be hearing the compressor). Post back, and include brand and model of AC).
__________________
LadyWindrider
2012 Ford F250 ext. Cab 4x4
2002 Jeep Wrangler Sahara
2008 Yamaha V-Star 650 Classic

2008 Work and Play 18LT
LadyWindrider is offline   Reply With Quote
Old 05-29-2011, 10:56 PM   #8
Senior Member
 
M109Rrider's Avatar
 
Join Date: Oct 2010
Location: Chesapeake, Va
Posts: 750
The crusader a/c is different, it's completely ducted and doesn't penetrate into the ceiling like most others (no quick cooldown). It has recirc inlet almost like a home a/c in the ceiling above the kitchen. Sounds like the compressor is running but not the blower motor. I'd check the fuses/bkr. Maybe turn off/pull fuse and turn back on. Could be a thermostat issue too. The thermostat is kinda tricky to use if your not familiar with it. Using the thermostat you can manually turn the fan on. Sorry I'm not more help.
__________________

Jason and Billie
2005 Dodge Ram 2500, 4X4, QC/SB 5.9L Cummins
15k non-sliding Hidden Hitch (they lied, it's not hidden at all)
2011 Prime Time Crusader 320RLT
"PT Crew Member Since 11/2010"
M109Rrider is offline   Reply With Quote
Old 05-29-2011, 11:03 PM   #9
Senior Member
 
M109Rrider's Avatar
 
Join Date: Oct 2010
Location: Chesapeake, Va
Posts: 750
Had to look at mine to refresh my memory. There is only 1 breaker. If you put your thermo in fan mode then use the +/- buttons to select between hi lo and auto. put in hi/lo and see if fan runs. If it does I'd venture to say it's a problem with the thermostat....i.e. it's not tell the blower to come on when in A/C mode. There's a small delay for the fan to turn on and turn off.
__________________

Jason and Billie
2005 Dodge Ram 2500, 4X4, QC/SB 5.9L Cummins
15k non-sliding Hidden Hitch (they lied, it's not hidden at all)
2011 Prime Time Crusader 320RLT
"PT Crew Member Since 11/2010"
M109Rrider is offline   Reply With Quote
Old 05-29-2011, 11:53 PM   #10
Senior Member
 
grhodes50's Avatar
 
Join Date: Dec 2007
Location: Eastern Oklahoma, USA
Posts: 2,450
Thanks Jason. I learn something new everyday. My problem is tryin' to remember what I learned.
__________________

__________________

Gary & Trish
"PT Crew Member Since 11/2010"
2011 LaCrosse 303 RKS Touring Edition : 2007 Flagstaff 206ST MAC Series
2012 F-250 Lariat : FX4 : CC : SB : 6.7L Diesel : 3/55 Gears

2014 Nights Camped - 3
grhodes50 is offline   Reply With Quote
Reply

Tags
air conditioning

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


All times are GMT -5. The time now is 10:11 AM.