Reply
 
Thread Tools Display Modes
Old 05-16-2011, 01:09 PM   #1
Member
 
Join Date: Aug 2010
Posts: 38
Cassette Toilet doesnt flush

I started this thread last fall, so i'm including a link in case you need any additional info: Winterize toilet

After reading and research, I realized the toilet has its own water supply, which I filled. However, when I push down the flush knob, nothing happens. Last fall, there was a mechanical pump of some kind that sprayed water into the bowl. Now, nothing at all. Is there a reset switch I missed? An On/Off switch? I have full AC and DC power connected.

Any Suggestions?
__________________

__________________
fisk is offline   Reply With Quote
Old 05-16-2011, 02:06 PM   #2
Senior Member
 
flyrotor's Avatar
 
Join Date: Sep 2009
Posts: 755
It's possible after reading the linked thread that you didn't get the toilet winterized completely and you froze a line somewhere in your cassette toilet. Also, there should be a clear tube to indicate your water level in the fresh tank, make sure it is connected correctly, that may be a source of loosing the pressure created to flush... just a suggestion.

Also, it probably is a Thetford toilet, check their website to see if they have a better owner's manual that may help you trouble shoot the problem
__________________

__________________
flyrotor is offline   Reply With Quote
Old 05-16-2011, 02:37 PM   #3
Member
 
Join Date: Aug 2010
Posts: 38
unfortunately, you may be correct about not winterizing it properly. I held down the flush knob until the water stopped coming out, but that doesnt mean it was all gone from the system.

Does this use a small, DC powered, pump to suck the water out of the holding tank and push it to the bowl when someone flushes the toilet? Right now, there is no noise or movement at all when I push down on the flush knob. That's why I was wondering if there was a reset button or something similar that would restart it.
__________________
fisk is offline   Reply With Quote
Old 05-16-2011, 02:51 PM   #4
Senior Member
 
flyrotor's Avatar
 
Join Date: Sep 2009
Posts: 755
Not from my past experience does it have an electric pump. I have since sold the trailer with the pump, but it seems that it created suction when turning the pump lever to the side, if I still had the trailer I would go check it for you, sorry
__________________
flyrotor is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:25 PM.