Reply
 
Thread Tools Display Modes
Old 07-01-2019, 12:57 PM   #1
Junior Member
 
Join Date: Jul 2018
Posts: 10
Fuel station quit working

When I press the switch next to the fuel gauge I hear a click but the pump does not run. I checked the fuse and power to is and it is good. Checked power into the 5 minute timer and it is good. Replaced the 5 minute timer and still have the same problem. Is there another fuse for the pump. The only one I found was behind the gauge panel. The fuel station was working last time I check it which was a couple of months ago.
__________________

Bgotro47 is offline   Reply With Quote
Old 07-01-2019, 01:17 PM   #2
Member
 
keegantimber's Avatar
 
Join Date: Feb 2018
Posts: 73
A couple years ago mine quit. So Im going from memory here. I found the pump was receiving the proper 12v and ground. I took the pump off and apart. I found the plastic gears in the pump to be a tad scored. Im gonna guess from contaminants in the tank. I lightly sanded the sides of the gears and lubed with a little oil. I believe I did a dry run and all was good. Reinstalled the pump AND added an in line filter between the tank and the pump.
keegantimber is offline   Reply With Quote
Reply

Tags
fuel

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:34 AM.


×