Reply
 
Thread Tools Display Modes
Old 08-25-2014, 03:12 PM   #1
Junior Member
 
Join Date: May 2013
Posts: 2
Fuel Station - XLR ToyHauler

We've been using our fuel station for 2 years now, but this weekend wouldn't kick on. Normally when you hit the button near the gauges you can hear the pump kick on, but now gauges don't work and pump doesn't kick on. Checked the fuse in the main fuse cabinet and it is fine. Anyone else run into this problem? Any suggestions?

Thanks!
__________________

__________________
Wyoboy is offline   Reply With Quote
Old 08-25-2014, 04:09 PM   #2
Junior Member
 
Join Date: Oct 2013
Posts: 20
I had a similar issue and after reading some posts on here I removed the lower part of the pump and bled some gas out. It is a section parallel with the gas flow through the pump. Gas will come out so be careful.

I must have had a obstruction because the pump now works with just a little gas being removed.
__________________
Berkdawg is offline   Reply With Quote
Reply

Tags
xlr

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:30 PM.