Thread Tools Display Modes
Old 09-19-2010, 01:16 PM   #1
Junior Member
Join Date: Nov 2009
Location: Lanexa,Va.
Posts: 19
Generator Runs, but Quits

I've got an '07 Forester 2941DS,with a Onan 4.0, I just changed the oil in the generator, then started it to let it run, it ran about 30 min., then quit, rechecked the oil, looked a little low, so I filled it to the full mark, & started it again, ran about 10 mins. & quit again.
The fuel tank is full, the air filter is clean, any thoughts?

bukhrn is offline   Reply With Quote
Old 09-19-2010, 03:31 PM   #2
Senior Member
tmmar's Avatar
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,200
Welcome to the forums. If it's water cooled it could be overheating??
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:39 AM.