Thread Tools Display Modes
Old 06-27-2012, 10:04 PM   #11
Join Date: May 2010
Location: Illinois
Posts: 38
Just wanted to update this thread....

I found the problem with my fridge, furnace, and bunkhouse lights...

I knew the issue had to be wiring since the trouble was isolated to this area of the camper.

we had checked the fuses and visible wiring.... but i went to check -for the 4th time- the fuses and as I grabbed the fuse for fridge/furnace, the bunkhouse lights came on...??? The fuse was ok.... the soldered pins of the fuse housing were loose...

So I moved the wire from this fuse to an open, unused fuse and everything works.

Brad & Melissa
2002 Ford Expedition 4X4 4.6 ltr
1999 ForestRiver Flagstaff 829BHS
braddaddy is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:28 AM.