Reply
 
Thread Tools Display Modes
Old 07-05-2016, 07:16 PM   #1
Junior Member
 
Join Date: Jul 2016
Posts: 2
Inverter

Hello
I have a 2016 Heritage Glen 386 fbk the unit has a wfco inverter to run the residential fridge. When I picked the unit up the led read out read 12.5 and the green light was on. Now the yellow light is on and the read out is 11.6 with the empty battery icon flashing fridge is still cold however and the panel for the battery reads full this unit has two battery. I have had this to the dealer for this issue dealer stated it was the truck. I don't believe this as I can have the unit plugged in at camp for three days and as soon as I unplug to go home and turn the inverter on it goes back to 11.6 and the yellow light is on as well. Any advice you could give me to go back to the dealer with
__________________

__________________
Big 386 is offline   Reply With Quote
Old 07-06-2016, 11:04 AM   #2
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 4,322
Need to have the batteries load tested.

Were the batteries in the unit when you purchased it?
Is there a date punched on the batteries?
Are the batteries wired parallel?
__________________
Salem 29RKSS Pushing a GMC Sierra 2500HD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Reply

Tags
inverter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:42 PM.