Thread Tools Display Modes
Old 08-31-2016, 12:06 PM   #1
Junior Member
Join Date: Aug 2016
Posts: 1
Level controller panel has no power

I Have a 2008 Georgetown 338 I recently purchased. The LCI panel does not seem to have any power. Nothing lights up when the power button is pushed. Is there a fuse that I should be looking for? The ignition is on an the brake applied but still no power.

Notso is offline   Reply With Quote
Old 09-13-2016, 10:57 AM   #2
Junior Member
Join Date: May 2014
Posts: 1
Check for a fuse next to your house batteries. I have a 2012 378 , and the batteries are in the steps. Also,check for the main breaker blowing.
Rdarrow11 is offline   Reply With Quote

controller, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:51 AM.