Reply
 
Thread Tools Display Modes
Old 04-24-2015, 03:42 PM   #11
Junior Member
 
Join Date: Apr 2015
Location: Florida
Posts: 10
Made an appointment with Tampa truck center they are a certified Mercedes repair shop with the correct diagnostic computer obd2 will not work with this system lower tech. This unit does not have the dpf fluid not sure what that is the older units used it. Not a turbo eng hope it's just a computer flash everything is like new. Will update when I get a diagnosis.
__________________

__________________
Travelinman is offline   Reply With Quote
Old 04-24-2015, 04:12 PM   #12
Senior Member
 
Join Date: Dec 2014
Location: oakdale, ca
Posts: 289
I agree on it being a firm ware issue. I had a similar issue with my tow rig and it ended being 2 things they needed to up date the firm ware and they had a recall on one of the computers over heating causing issues. They installed a larger fan on the system for cooling. No problems now.
__________________

__________________
j free is offline   Reply With Quote
Old 04-24-2015, 05:42 PM   #13
Senior Member
 
Join Date: Apr 2012
Location: South Carolina
Posts: 1,254
A friend had the same problem with his Class A Freightliner. Turned out to be a bad sensor. I think it was the water in fuel sensor. Happened several times. Finally got to a Freightliner dealer who diagnosed it.
__________________
RamblerGuy
2011 Sunseeker 3100
1997 Pathfinder Toad
RamblerGuy is offline   Reply With Quote
Old 04-25-2015, 04:08 PM   #14
Junior Member
 
Join Date: Apr 2015
Posts: 7
I had a 2009 sprinter with that same problem, ended up to be the EGR valve replaced it end of problem
__________________
northdakota is offline   Reply With Quote
Old 04-29-2015, 11:36 AM   #15
Junior Member
 
Join Date: Apr 2015
Location: Florida
Posts: 10
Ok guys got the good and bad news I was able to get it into limp mode and took it right to Tampa truck center they did an express write up and found a soft code for the egr valve. Bad news is they want 1.100$ to replace it.I am a little shocked at 17k but who knows have read that they can be cleaned I am a certified master mech and think I will give it a shot if not I will replace it.
__________________
Travelinman is offline   Reply With Quote
Old 04-29-2015, 02:24 PM   #16
Junior Member
 
Join Date: Jan 2015
Posts: 7
Life was much less expensive before emission control... sorry to hear that. Good luck cleaning the one you have. Please post results.
__________________
Douglas Houston
Flower Mound,TX
1999 2500 Suburban
2013 WFKSS-30 V-Lite
2015 - 209 days
dhouston16 is offline   Reply With Quote
Old 04-29-2015, 02:30 PM   #17
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
I bet if you look around someone is offering a egr delete for that unit.
Unless by law you are required to pass an emissions test

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "2 nights"
__________________
TURBS is offline   Reply With Quote
Old 04-29-2015, 02:32 PM   #18
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
http://m.dieselspec.ca/6-brand-mercedes.html?cat=2



TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "2 nights"
__________________
TURBS is offline   Reply With Quote
Old 04-29-2015, 06:10 PM   #19
Junior Member
 
Join Date: Apr 2015
Location: Florida
Posts: 10
After talking with Good Sam and going over the contract the egr valve is not a covered item of course it's not and 1,100.00 is out of the question. Trekked back to retrieve the coach and the svc advisor Nichole took care of me after I explained my situation she only charged me 25.00 for diagnosis not the 125.00 I signed for. The estimate was for 3.0 hrs in labor at 145.00 an hr and 525.0. in parts . Being a tech for many years I popped the hood expecting to see the valve buried and a pia to get out. To my joy it was right there in my face and took me all of 17 minutes to remove. I was surprised to find that it was clogged and the valve was stuck in the halfway position. There were a couple of videos on U Tube about cleaning them and after some further research on the sprinter forum I have found this to be a common problem and a flaw in the design. Going to get some Seafoam cleaner in the am and soak it clean it and reinstall will see what happens if it fails I have access to sprinter parts and my cost for the valve would be 325.00,200.00 less than the dealer.Will keep you posted.
__________________
Travelinman is offline   Reply With Quote
Old 05-09-2015, 06:39 PM   #20
Junior Member
 
Join Date: May 2015
Posts: 3
My f150 does the same thing when i manually operate the trailer brakes. Once i got the trailer brake module where i wanted it, it has never done it since.
__________________

__________________
rominks is offline   Reply With Quote
Reply

Tags
power, modifications

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:45 PM.