Thread Tools Display Modes
Old 05-16-2015, 06:25 AM   #1
Junior Member
Join Date: Oct 2014
Posts: 22
loses acceleration

We bought a 2014 FR3 last April. We noticed an occasional loss of acceleration but no dash lights come on and it only lasted a few seconds each time. We did not drive it much last year. This April we drove from Ohio to the Grand Canyon and there were many scary times. The motorhome loses power and it kept getting worse. As soon as we got back home we took it in for repairs. It's been in for the fifth time now. The Ford people nor the trucking repair techs seem to be able to fix the problem even with putting it on the computer. Anyone else having this problem?
gfritz1939 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:36 PM.