Reply
 
Thread Tools Display Modes
Old 10-03-2011, 11:15 AM   #1
Junior Member
 
Join Date: Oct 2009
Posts: 24
Need help trouble-shooting electrical problem

Last weekend I ran into an electrical problem I can't figure out (rig is a 2010 Sunseeker 3210). The heater fan cycles and the lights dim (or flicker on and off) ONLY when I'm hooked up to shore power and ONLY when I have the battery switch in bypass (ie battery switch to 'off'). If I put the batteries to 'on' the problem goes away and if I unplug from shore power the problem goes away. I know it's not the shore power source because it's happenning at different plugins at different homes. Any ideas on where to start checking?

Thanks
__________________

__________________
Cougguy is offline   Reply With Quote
Old 10-03-2011, 11:41 AM   #2
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
Quote:
Originally Posted by Cougguy View Post
Last weekend I ran into an electrical problem I can't figure out (rig is a 2010 Sunseeker 3210). The heater fan cycles and the lights dim (or flicker on and off) ONLY when I'm hooked up to shore power and ONLY when I have the battery switch in bypass (ie battery switch to 'off'). If I put the batteries to 'on' the problem goes away and if I unplug from shore power the problem goes away. I know it's not the shore power source because it's happening at different plugins at different homes. Any ideas on where to start checking?

Thanks
this sounds like a ground problem. The heater is all DC and it needs a path to get back to ground on the converter. When you are in Battery bypass, the ground on the battery is not available to complete the circuit for the heater and it relies on the converter ground to find "ground."

Having said that, this might not be an easy fix. Since the "FRAME" is the ground circuit, and convenient place to put a self tapping screw becomes the "ground of choice" for just about everything in your camper. I found three when I had the belly covering off doing my Horst mod.

One of those was for the Concertone and a corroded or rusted ground connection there causes 90% of the reported sync problems with the video. Try to find the place where the furnace is grounded and clean up the connection.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:46 AM.