Reply
 
Thread Tools Display Modes
Old 02-21-2011, 02:04 PM   #1
Member
 
Join Date: Jan 2011
Posts: 41
no power to front TV with generator on

Our new Forester has 3 TV's. The rear two run off of 12 volts but the front one doesn't. When we first looked at this new unit, the MH was plugged in and the front TV was on. Now the other day I fired up the generator and to my surprise the front TV wouldn't power up. I didn't have anything else to test the outlet that its plugged in to.

Any ideas? Surely this TV should work when the generator is on right?

thanks.
__________________

__________________
2011 Forester 3171DS Pic
torino421 is offline   Reply With Quote
Old 02-21-2011, 02:09 PM   #2
Senior Member
 
Join Date: Dec 2010
Posts: 517
Send a message via Skype™ to scubieman
Correct, It should. Now that's do a few other tests. For example test other 110/outlets to see if there is a switch for using generator power/shore power. Also find the fuse/breaker for that tv to make sure it's not tripped/blown.
__________________

__________________
2009 Dodge Ram Mega Cab 2500 6.7 cummins
2011 Forest River Cherokee 28BHKS

scubieman is offline   Reply With Quote
Old 02-21-2011, 02:17 PM   #3
Member
 
Join Date: Jan 2011
Posts: 41
Quote:
Originally Posted by scubieman View Post
Correct, It should. Now that's do a few other tests. For example test other 110/outlets to see if there is a switch for using generator power/shore power. Also find the fuse/breaker for that tv to make sure it's not tripped/blown.
I forgot to mention that I did check the fuses for the TV's and they are fine. I have one of those plugs that light up when you plug them in to an outlet so I will use that to test the other outlets.

thanks for responding, I will let you know what I find.
__________________
2011 Forester 3171DS Pic
torino421 is offline   Reply With Quote
Old 02-21-2011, 02:49 PM   #4
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135
Are you trying to turn it on by the remote?? Occasionally ours, Westinghouse HDTV, has to be unplugged then plugged back in. Then Press the power button on the TV and it's fine after that. Don't understand why but it's a possiblility that could be your fix if it's not anything else.
__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is offline   Reply With Quote
Old 02-21-2011, 02:49 PM   #5
Senior Member
 
dashonthedash's Avatar
 
Join Date: Oct 2010
Posts: 202
If you can't get power from any of your AC outlets, does your unit have an auto transfer switch? If there is no transfer switch, your shore power cord will need to be plugged into the generator outlet (usually in the same compartment as the cord) in order for you to get any power from the generator.
__________________

Gary Shapiro, 2011 Georgetown 29' Class A
Dash, Molly & Lily - now at the Bridge and forever in my heart
Shadow - 4-year-old Greyhound
Hannah - 1 1/2-year-old GSD rescue
dashonthedash is offline   Reply With Quote
Old 02-21-2011, 03:51 PM   #6
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,157
My GFCIs get goofy when on Generator. Check to see if any have tripped.
I have dumped my computer more than once when running the AC on generator and the GFCI lets go.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is online now   Reply With Quote
Old 02-21-2011, 08:07 PM   #7
Member
 
Join Date: Jan 2011
Posts: 41
there was a breaker on the generator that was off. Flipped it on and everything works! That made my day, now why was it off? Maybe since it was new nobody turned it on to begin with, as long as it stays on I'm happy. This is all new to me so I'm learning every time I step in to it.

Oh and there must be an auto transfer switch because when the generator first started it took about 30 seconds or so before things worked. First thing I heard was a beep from the microwave, then i verified all outlets worked including the front TV.

thanks everyone for your comments and suggestions!
__________________

__________________
2011 Forester 3171DS Pic
torino421 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:18 PM.