Thread Tools Display Modes
Old 06-06-2012, 05:43 PM   #1
Junior Member
Join Date: Jan 2012
Posts: 1
Rear Camera Issue

I have a 2006 Georgetown 370 with a voyager backup camera system. The issue: Critters have chewed through my cable from the monitor to the camera. My question is how was the cable run from the monitor to the camera by Forest River? The main cable is destroyed and I'm going to have to replace it. Any help would be greatly appreciated.

Thank You

caalfs is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:20 PM.