Reply
 
Thread Tools Display Modes
Old 07-27-2016, 09:12 PM   #1
Junior Member
 
Join Date: Feb 2011
Posts: 25
Several control panel switches stopped working

Hi,

Wondering if you can help me locate a problem. A few days ago several light switches on the top row of my Sandpiper 365SAQ control panel stopped working. Namely "kitchen", "porch" and "scare". Can't find any breaker or fuse that is not working. Was wondering if there may be an inline fuse for this and where I might locate it. I tried looking behind the control panel but couldn't see one.

Anyone else had something like this and fixed it?

Thanks in advance,
Sahgie
__________________

__________________
2006 Chevy Silverado 3500 CC LT1 Dually
2011 Sandpiper 365SAQ
B&W Companion Hitch
Sahgie is offline   Reply With Quote
Old 07-28-2016, 11:12 AM   #2
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 3,592
If you have a multimeter you should check for 12 volts feeding the switches and at each switch that's not working. If you have +12 volts at and through the switches, then you'll need to start looking for a open negative somewhere along the line.
__________________

__________________
Salem 29RKSS Pushing a 2500 Mega-Cab CTD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 07-28-2016, 11:20 AM   #3
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 4,674
I'm thinking along Rambler's lines- I'd look for an open ground.
__________________
SEARCH is your friend!
FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49 / '14 = 74 / '15 = 74 / '16 = 85 / '17 = 42; booked = 20
Mr. Dan is online now   Reply With Quote
Old 07-28-2016, 11:30 AM   #4
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 2,567
If you haven't pulled the switch panel you may want to do that and check the connection that was made tying the 12V to those switches they are only crimped connections
__________________
Retired Navy
Jake my sidekick (yellow Lab)
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM of Idaho
SeaDog is online now   Reply With Quote
Old 07-28-2016, 01:38 PM   #5
Senior Member
 
Join Date: Jan 2013
Posts: 151
Switches

I had the exact same problem and, after checking everything else, I ordered new ones. The only place that I could find that sells the exact same ones is BURNSTINES DISTRIBUTING, BRISTOL IN. The lady on the phone was extremely helpful and there was no problem. The new ones work great.
__________________
VMI'62
Edmund is offline   Reply With Quote
Old 07-28-2016, 01:44 PM   #6
Member
 
Join Date: Jul 2016
Posts: 99
Check these tiny black buttons

Those black buttons on the left of this panel are actually reset switches. This is by the batteries.
http://www.forestriverforums.com/for...1&d=1469731346
Attached Thumbnails
Click image for larger version

Name:	20160728_131853.jpg
Views:	58
Size:	366.7 KB
ID:	115643  
__________________
If not camping, I am Sailing
JohnVtx is offline   Reply With Quote
Old 07-28-2016, 07:42 PM   #7
Senior Member
 
Join Date: Feb 2016
Posts: 148
I've had it happen to other 12v switches and it turned out to be a loose ground connection.
__________________
DrLewie is offline   Reply With Quote
Old 07-28-2016, 08:42 PM   #8
Junior Member
 
Join Date: Jul 2014
Location: Allenspark, CO
Posts: 10
Quote:
Originally Posted by SeaDog View Post
If you haven't pulled the switch panel you may want to do that and check the connection that was made tying the 12V to those switches they are only crimped connections
X2 - I had the water pump switch quit working. The pilot light on the switch was on, but no power to the pump. I pulled the switch panel off and found the +12 that feeds all of the switches had come out of the crimp.
__________________
2006 Silverado 2500HD
2014 Flagstaff 21FBRS
bcmcdonald is offline   Reply With Quote
Old 07-28-2016, 10:08 PM   #9
Junior Member
 
Join Date: Feb 2011
Posts: 25
Thanks guys for all the suggestions. Seems to me like a loose 12v also as it affects only these three switches and it happened on all three all at once. I did have a quick glance initially and couldn't find anything wrong with the wiring behind the panel as well as under the fridge where most of the cables go.
I bought a multi,enter today and will have a check with it and will keep posted.
__________________

__________________
2006 Chevy Silverado 3500 CC LT1 Dually
2011 Sandpiper 365SAQ
B&W Companion Hitch
Sahgie is offline   Reply With Quote
Reply

Tags
switch

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:30 PM.