Reply
 
Thread Tools Display Modes
Old 05-11-2013, 08:16 PM   #1
Member
 
AlWaysSumptin's Avatar
 
Join Date: Apr 2010
Location: Central Iowa
Posts: 31
Speaker removal

Speaker not working in our 2010 Rockwood 2304S and I want to swap it with one that works but don't see how to get the small pods apart. Thought I'd do that before messing with anything else.
__________________

__________________
Still dragging around our 2010 Rockwood 2304S
with our 2008 Dodge RAM 2500
AlWaysSumptin is offline   Reply With Quote
Old 05-11-2013, 09:26 PM   #2
Senior Member
 
jtstromsburg's Avatar
 
Join Date: Jul 2011
Location: Stromsburg, Nebraska
Posts: 1,654
How bout a picture. Not sure, but if you mean the little surround sound speakers, well, I guess I'm not sure. Gonna hafta look at mine....
__________________

__________________
Joel and Teresa
2016 Sabre 34TBOK
2006 GMC 3500 CC LB DRW 4X4
jtstromsburg is offline   Reply With Quote
Old 05-11-2013, 11:15 PM   #3
Member
 
AlWaysSumptin's Avatar
 
Join Date: Apr 2010
Location: Central Iowa
Posts: 31
Ya, I knew no photo was going to be a problem and would be of some help but thought maybe I'd run this by just in case someone may have had the same problem.
I took a picture to add to the post but something fishy going on. I had to install Chrome just to post the question and still can't post photos. I have no trouble anywhere else posting on forums, just here so far. I'm working on it.

Anyway, I have 2 speakers above the slide and 2 above the couch, plus 2 outside. One of them inside isn't working but I don't see a way to get 'em apart. They are not very big, about a little larger than a pack of cigs.
__________________
Still dragging around our 2010 Rockwood 2304S
with our 2008 Dodge RAM 2500
AlWaysSumptin is offline   Reply With Quote
Old 05-11-2013, 11:19 PM   #4
Member
 
jwwilson's Avatar
 
Join Date: Nov 2012
Location: Bradenton
Posts: 53
Prolly a silly question but have you checked to make sure they are all plugged in to the amplifier?
__________________
jwwilson is offline   Reply With Quote
Old 05-11-2013, 11:34 PM   #5
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Quote:
Originally Posted by jwwilson View Post
Prolly a silly question but have you checked to make sure they are all plugged in to the amplifier?
Not silly at all. They seem to work their way apart with some frequency here.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 05-11-2013, 11:37 PM   #6
Member
 
AlWaysSumptin's Avatar
 
Join Date: Apr 2010
Location: Central Iowa
Posts: 31
Yes. Pulled the radio out and everything looks alright on that end. If I could swap a pair of speakers that would narrow it down a little. Easier than cutting wires at the radio. Probably no output on that channel but connecting a known good speaker would help. Maybe the grill snaps out, doesn't look like it, but who knows.
__________________
Still dragging around our 2010 Rockwood 2304S
with our 2008 Dodge RAM 2500
AlWaysSumptin is offline   Reply With Quote
Old 05-12-2013, 07:49 AM   #7
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
I have had my speakers down (I was looking at "upgrading" them) and they look like sealed units. I decided other things needed doing first as mine worked.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 05-12-2013, 08:36 AM   #8
Member
 
AlWaysSumptin's Avatar
 
Join Date: Apr 2010
Location: Central Iowa
Posts: 31
Here it is. Gonna go out and take another swing at it..
Attached Thumbnails
Click image for larger version

Name:	111 Rockwood speaker.jpg
Views:	74
Size:	30.9 KB
ID:	30208  
__________________
Still dragging around our 2010 Rockwood 2304S
with our 2008 Dodge RAM 2500
AlWaysSumptin is offline   Reply With Quote
Old 05-12-2013, 11:55 AM   #9
Member
 
AlWaysSumptin's Avatar
 
Join Date: Apr 2010
Location: Central Iowa
Posts: 31
Stuck some jumper wires in the connector and scratched across a AA battery for each speaker. All seem OK. Looks like the old Concertone is shot already. Never used it that much anyway but it should have lasted longer then this.
__________________
Still dragging around our 2010 Rockwood 2304S
with our 2008 Dodge RAM 2500
AlWaysSumptin is offline   Reply With Quote
Old 05-12-2013, 06:34 PM   #10
Member
 
AlWaysSumptin's Avatar
 
Join Date: Apr 2010
Location: Central Iowa
Posts: 31
I gave up. Didn't want to destroy anything. Thanks for the help.
__________________

__________________
Still dragging around our 2010 Rockwood 2304S
with our 2008 Dodge RAM 2500
AlWaysSumptin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:43 AM.