Thread Tools Display Modes
Old 07-03-2010, 02:06 PM   #1
Junior Member
Join Date: Jul 2010
Posts: 6
Toilet Pump on High Wall Pop up

Hi All.
I'm new here. Nice to find this place. We have an 05 Rhino High Wall. This is our third season and love it. We get lots of comments and compliments, but more importantly we enjoy it. Anywhoooo, last summer, one night, I went to flush the potty. It has the press to pump kind and nothing...not water. Hubby has taken the whole thing apart, changed the flasher like relay, yesterday he located a 3A fuse, which I scoured Ace for and replaced that. Nothing. No water flows when you pump. Does anyone know WHERE the pump is in this potty? He said it is definitely getting power. All our other water works fine including the shower that is part of the built in unit.
Thanks in advance for any ideas.
wildcatwmn is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:43 PM.