Thread Tools Display Modes
Old 08-16-2010, 07:55 AM   #1
piscesman's Avatar
Join Date: Jan 2010
Location: Prince Edward Island, Canada
Posts: 66
Transmission leak...Ford 550 chassis

I have a 2003 Georgetown on a Ford 550 chassis and less than 20,000 miles...and I have recently found evidence of transmission fluid under the rig after I returned from a 3-day outing. It's a lot more than a few drops, but only looks wet from the pan gasket down...fluid level is still OK and no evidence of overheating/scorching. I have never added more fluid. I have tightened the pan bolts to see if that helps...does anyone have any info or suggestions before I head for the Ford dealer in town?? Thanks!


Nights camped in 2011: 108
Nights camped in 2012: 41
piscesman is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:49 PM.