Reply
 
Thread Tools Display Modes
Old 10-28-2015, 09:54 PM   #1
Senior Member
 
jmgllt's Avatar
 
Join Date: Feb 2015
Posts: 129
Allison 2500 transmission display

I bought my Berkshire used, and have problems seeing the RND shift modes at night. Should it be back lit with the head lights?
__________________

__________________
jmgllt is offline   Reply With Quote
Old 10-28-2015, 10:00 PM   #2
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
It should light up brightly. Turn the roller switch next to the headlight switch.
__________________

__________________
Phil57 is offline   Reply With Quote
Old 10-28-2015, 10:13 PM   #3
Senior Member
 
jmgllt's Avatar
 
Join Date: Feb 2015
Posts: 129
Quote:
Originally Posted by Phil57 View Post
It should light up brightly. Turn the roller switch next to the headlight switch.

Yea that's what I thought, tried that but got nothing. I'm thinking I might have a light bulb burnt out.
__________________
jmgllt is offline   Reply With Quote
Old 10-28-2015, 10:25 PM   #4
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Odd that should not just be one bulb. Maybe but I think there are several in there. Maybe a fuse? I would look at the 12v compartment below the driver.
__________________
Phil57 is offline   Reply With Quote
Old 10-28-2015, 10:26 PM   #5
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Still thinking here do you have map lights? Do they work.
__________________
Phil57 is offline   Reply With Quote
Old 10-28-2015, 11:06 PM   #6
Senior Member
 
jmgllt's Avatar
 
Join Date: Feb 2015
Posts: 129
Yes the map lights do work
__________________
jmgllt is offline   Reply With Quote
Old 10-28-2015, 11:21 PM   #7
Senior Member
 
jmgllt's Avatar
 
Join Date: Feb 2015
Posts: 129
Quote:
Originally Posted by Phil57 View Post
Still thinking here do you have map lights? Do they work.

Yes the map lights do work
__________________
jmgllt is offline   Reply With Quote
Old 10-28-2015, 11:24 PM   #8
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
I'm stumped. I'll look at mine in the morning. Someone has had this happen I would bet they will have a fix. Sorry.
__________________
Phil57 is offline   Reply With Quote
Old 10-29-2015, 08:44 AM   #9
Senior Member
 
Join Date: Feb 2015
Posts: 741
Quote:
Originally Posted by Phil57 View Post
Still thinking here do you have map lights? Do they work.

My 2014 390-BH 60 doesn't have map lights😂


Paul
Sent from my iPad using Forest River Forums
__________________
Paulie Boy is offline   Reply With Quote
Old 10-29-2015, 02:05 PM   #10
Senior Member
 
Join Date: Aug 2015
Location: Easley, South Carolina
Posts: 645
Quote:
Originally Posted by Paulie Boy View Post
My 2014 390-BH 60 doesn't have map lights😂


Paul
Sent from my iPad using Forest River Forums
Ditto, but who reads maps anymore? Didn't they follow phone books ?
__________________

__________________
Joe & Lori

2014 Berkshire 390 RB-40
5456Mich is offline   Reply With Quote
Reply

Tags
500

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:18 PM.