Reply
 
Thread Tools Display Modes
Old 11-24-2013, 06:33 PM   #1
Berkshire club
 
Berkshire Driver's Avatar
 
Join Date: Sep 2013
Location: Texas
Posts: 59
Aux Start Switch Light?

Hey all my 2014 Berkshire has a ghost? when i was out in the coach in storage at home i noticed that my Aux Start light on the inside control panel was on but just very faint, sometimes the light kinda goes brighter and then fade out, very strange has anyone noticed strange occurrence on there Coach or do i need a Ghostbuster?
__________________

__________________
Berkshire Driver is offline   Reply With Quote
Old 11-24-2013, 06:36 PM   #2
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
This is a common occurrence with the coach. Happened with my '08 and happens with my '14. Never caused any problems and no one has found out why this happens. This has been discussed before and I wouldn't worry about it.
__________________

__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 11-25-2013, 12:11 AM   #3
Berkshire 390QS
 
NO3putt's Avatar
 
Join Date: Feb 2011
Location: Pueblo Colorado
Posts: 1,250
Ours does the same thing, but never had a problem.
__________________
2011: 54 days, 2012: 218 days, 2013: 175 days, 2014: 196 days
2015: 188 days, 2016: 72 days, 2017: 185
2009 Berkshire, 390QS, and toad
Skip
NO3putt is offline   Reply With Quote
Old 11-25-2013, 06:20 AM   #4
Senior Member
 
Witch Doctor's Avatar
 
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 7,610
Quote:
Originally Posted by Berkshire Driver View Post
Hey all my 2014 Berkshire has a ghost? when i was out in the coach in storage at home i noticed that my Aux Start light on the inside control panel was on but just very faint, sometimes the light kinda goes brighter and then fade out, very strange has anyone noticed strange occurrence on there Coach or do i need a Ghostbuster?
Why don't you try putting in a new switch? It's cheap enough. See if that will end your problem you getting voltage bleed off from something. It could be the switch itself. Just a guess here.
__________________
Rockwood #8289 WS 2012
F250 6.0 / Husky 16k
With 4 point leveling system
Witch Doctor is online now   Reply With Quote
Old 11-25-2013, 10:12 AM   #5
Senior Member
 
NV245's Avatar
 
Join Date: Jun 2013
Location: Carmel, In
Posts: 175
In the thread Berkshire aux start and charging, AREA51 found that the light goes off if house batteries are below 13.3V.
__________________
NV245 is offline   Reply With Quote
Old 11-25-2013, 11:28 AM   #6
Senior Member
 
Join Date: Nov 2012
Location: Home is where I park it
Posts: 1,503
Mine doesn't fade in and out..... But it does blink every minute or so.

Boowho??
__________________
boowho is offline   Reply With Quote
Old 11-26-2013, 12:14 AM   #7
Senior Member
 
Join Date: Sep 2012
Posts: 188
....have an '08 and mine does the same, stays on all the time. No worries.
__________________

__________________
James
2008 Berkshire 360QS-40
"If you can't fix it with a hammer, you have an electrical problem"
speedmerchant is offline   Reply With Quote
Reply

Tags
light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:57 PM.