Reply
 
Thread Tools Display Modes
Old 10-05-2015, 01:28 PM   #1
Fulltime in our Berkshire
 
KennyGolub's Avatar
 
Join Date: Oct 2014
Posts: 882
Camera on Mirror

Did anyone with a Berk have a problem where one (left) of the side view cameras comes back with a blank, white screen when turning on the turn signal ?

Thanks,
Ken
__________________

__________________
Ken & Laurie
2015 Berkshire 400QL
2016 Chevy Colorado
Home is Where we park it
KennyGolub is offline   Reply With Quote
Old 10-05-2015, 01:56 PM   #2
Senior Member
 
Join Date: Feb 2015
Posts: 741
Yes but only for a split second. The right camera does it as well.


Paul
Sent from my iPad using Forest River Forums
__________________

__________________
Paulie Boy is offline   Reply With Quote
Old 10-05-2015, 02:02 PM   #3
Fulltime in our Berkshire
 
KennyGolub's Avatar
 
Join Date: Oct 2014
Posts: 882
My left side camera is dead.....

Guess it's never too early to start the Goshen list ...

Thanks for the reply.

Ken
__________________
Ken & Laurie
2015 Berkshire 400QL
2016 Chevy Colorado
Home is Where we park it
KennyGolub is offline   Reply With Quote
Old 10-06-2015, 07:34 AM   #4
Senior Member
 
15berkxl's Avatar
 
Join Date: Mar 2015
Location: Mishawaka
Posts: 576
Quote:
Originally Posted by KennyGolub View Post
My left side camera is dead.....

Guess it's never too early to start the Goshen list ...

Thanks for the reply.

Ken

Ken my right camera went dead on the maiden voyage but dealer found it was not the camera but the viewing unit. They switched camera leads on back of the unit and camera worked fine. Had to replace radio etc to solve problem.


Wayne
__________________
Wayne
15berkxl is offline   Reply With Quote
Old 10-06-2015, 10:45 AM   #5
Fulltime in our Berkshire
 
KennyGolub's Avatar
 
Join Date: Oct 2014
Posts: 882
Quote:
Originally Posted by 15berkxl View Post
Ken my right camera went dead on the maiden voyage but dealer found it was not the camera but the viewing unit. They switched camera leads on back of the unit and camera worked fine. Had to replace radio etc to solve problem.


Wayne
Thanks Wayne.

I will try that this weekend.

Ken
__________________
Ken & Laurie
2015 Berkshire 400QL
2016 Chevy Colorado
Home is Where we park it
KennyGolub is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:37 AM.