Reply
 
Thread Tools Display Modes
Old 03-26-2014, 06:47 PM   #11
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Frank does the radio/GPS work with the cameras ok. I was thinking of redoing the sound system in my 2011 and am looking for ideas. Cost model ect.
__________________

__________________
Phil57 is offline   Reply With Quote
Old 03-26-2014, 07:23 PM   #12
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,507
Quote:
Originally Posted by frankatp View Post
I had a new Kenwood GPS/tuner installed when my rig was brand new and have the factory unit if you are interested. it may be something in the unit and not the wiring. Best of luck. Frank
What did you want for it Frank?
I am way too far away from my dealer to take it back to them for this issue.
Dan

Sent from my DROID BIONIC using Forest River Forums mobile app
__________________

__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is online now   Reply With Quote
Old 03-26-2014, 08:37 PM   #13
Cyclone
 
beipers's Avatar
 
Join Date: Nov 2012
Location: Iowa
Posts: 175
I would submit that if removing the input from the back of the radio solved the problem, The root cause is not the radio. It is in whatever powers the radio. What work did you just have done? Dumb question, do your back up lights come on when you disengage the air brake? If it were me, I'd put a meter on the wire you cut and verify you have signal there (not sure if it would be 12v, 5v or ground).

Sent from my SCH-R530U using Forest River Forums mobile app
__________________
2015 SOB 5th Wheel
2013 Chevrolet 3500 CC, DD SRW
1 Wife, 2 Kids under 5

Camping nights: 2015 - 19, 2014 - 39, 2013 - 48
beipers is offline   Reply With Quote
Old 03-27-2014, 08:42 AM   #14
Senior Member
 
frankatp's Avatar
 
Join Date: Jan 2013
Location: Archer Florida
Posts: 150
Phil and Dan, The unit I bought was a Kenwood DNX 890HD. It has video capability and all 3 cameras work. That being said, the cameras do not work when I put my signals on. The L-R cameras must be selected manually which I didn't mind since I use my mirrors and never really used the cameras anyway. Old school I guess. The DNX plays DVD's, CD's, and has all the features you would expect. I don't know why FR didn't put one in to begin with. The Garmin GPS is a great help. The unit fits perfectly in the space and took about 2 hrs to install. I also had new speakers put in the ceiling to replace the old ones. (I like my music loud)
If I could get a couple hundred bucks from the old one I would be happy Dan. We will be coming thru Dallas mid Sept or I could ship it to you if you were interested. Frank
__________________
frankatp is offline   Reply With Quote
Old 03-27-2014, 04:44 PM   #15
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,507
Frank, I played with the radio today and I can get the backup cam to come on by putting signal to the proper wire on the back. So I don't believe it is a radio problem. Thanks for the offer though.

And the more I use it believe I like it the way it is because I can activate the side cameras while backing up.
And I normally have the backup camera on all the time anyway.

Sent from my DROID BIONIC using Forest River Forums mobile app
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is online now   Reply With Quote
Old 03-28-2014, 08:18 AM   #16
Senior Member
 
frankatp's Avatar
 
Join Date: Jan 2013
Location: Archer Florida
Posts: 150
Fantastic Dan. I'm glad you got it to work. Did it come wired wrong from the factory?
Do you tow a car? I am getting our car set up and will leave the rear camera on with a split screen gps/camera when we start to tow. Good luck and keep us up to speed on how it's going. Frank
__________________
frankatp is offline   Reply With Quote
Old 03-28-2014, 09:59 AM   #17
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,507
Frank, yes it was wired wrong from the factory.
I picked it up new a couple weeks ago in Elkhart and now I'm in Texas.
Yes, I tow a car and like to keep an eye on it.

It was wired to the Air Park Brake somehow instead of Reverse gear.
Rear camera was activated when brake was released, but side cameras and radio would only work when the park brake was on.
Weird huh?
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is online now   Reply With Quote
Old 03-28-2014, 10:15 AM   #18
Senior Member
 
frankatp's Avatar
 
Join Date: Jan 2013
Location: Archer Florida
Posts: 150
Makes your wonder what else was wired wrong. We had some issues starting out with our 2013 390FL, but Randy at FR has been great to work with. We were at the FMCA rally in Perry Ga. and had our coach weighed. What a shock it was to find out we were overweight and didn't even have full tanks. We are going to Indiana in July to have an upgrade done to our coach.
Our son lives in Abilene and is retiring from the Air Force in September. Maybe we can stop and say hi on our way thru. Take care.
__________________

__________________
frankatp is offline   Reply With Quote
Reply

Tags
radio

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:02 PM.