Thread Tools Display Modes
Old 08-14-2016, 09:00 AM   #11
Senior Member
rattleNsmoke's Avatar
Join Date: Oct 2012
Location: Western Connecticut
Posts: 1,554
I would suspect a 'weak' battery or charging system. But then again I've been known to be way off base too.

2010 Cedar Creek 5th Wheel 34SATS "The Beast"
2006 Ford F350 Lariat 6.0L Diesel
2003 Harley Heritage Softail "Hogzilla"
1988 Harley Softail Custom "The Fireman"
1986 Marriage to "Wifey" (patience of a saint)
rattleNsmoke is offline   Reply With Quote
Old 08-14-2016, 10:10 AM   #12
Senior Member
Kenny kustom's Avatar
Join Date: Sep 2015
Posts: 2,196
Depending on length of time the message is displayed...

All vehicles will display the check engine light when starting.
It is a requirement of the emissions system to do a " bulb check" , to ensure the light works.

Not saying there may or may not be an issue.. just my 2 Canadian pennies.

2016 Sabre 36QBOK
2015 Ram 3500 CUMMINS
Bring Back The Search!

Kenny kustom is offline   Reply With Quote
Old 08-14-2016, 11:55 AM   #13
Senior Member
fredhardy's Avatar
Join Date: Apr 2014
Location: Phoenix
Posts: 109
Tom - the engine check light resolved itself. I would run it down the road and see what happens.

Fred Hardy
Phoenix, AZ
2014 Berkshire 390BH-60
2007 Explorer Sport Trac
fredhardy is offline   Reply With Quote
Old 08-15-2016, 12:04 PM   #14
Senior Member
tmmar's Avatar
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,195
I added about 3/4 gallon of antifreeze to the over flow tank (tank was down about 1/2 way). Also, I don't have a solid check engine light. The check engine light goes out after the bulb check finishes but I get a message on the screen that says '! Check Engine' but that goes off quickly also.
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 08-24-2016, 01:41 PM   #15
Junior Member
Join Date: Aug 2016
Posts: 2
Originally Posted by rattleNsmoke View Post
I would suspect a 'weak' battery or charging system. But then again I've been known to be way off base too.

My Low Battery lite would come and go, then on all the time, bad alternator.
F14man is offline   Reply With Quote
Old 09-02-2016, 04:22 PM   #16
Senior Member
Join Date: Jan 2014
Posts: 151
Had the same problem as F14 . Check your dash monitor for the voltage out put. I needed a new alternator also. If your voltage drops below a certain number your engine will shut down. Jim
jrlebaron is offline   Reply With Quote
Old 09-02-2016, 05:39 PM   #17
Senior Member
15berkxl's Avatar
Join Date: Mar 2015
Location: Mishawaka
Posts: 562
The confusing part of the monitor system is that there are three what I will call check engine lights. The first time I received a light I thought it was an engine concern but learned it was a light that looks like an engine but does not say anything but is for the monitor system it clears with 5 key activations. The other two one says check and the other says stop.


15berkxl is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:39 PM.