Reply
 
Thread Tools Display Modes
Old 08-22-2016, 10:24 AM   #1
Member
 
Join Date: Aug 2013
Location: Adirondacks
Posts: 45
Dash video screen went black

We are on the road. Initial start up at CG this morning video monitor was working. Rear camera, side cameras, radio screen all visible. Shut down for a short time. On start up, monitor screen totally black, no cameras or radio channels, info, etc. We replaced the original monitor with a Jensen. Still 600 miles from home. And music still playing but no touch screen. Any ideas - suggestions?
__________________

__________________
Doree and Neal,
2018 Cardinal 3850 RL Estate

ADK-RVer is offline   Reply With Quote
Old 08-23-2016, 10:31 AM   #2
Member
 
Join Date: Aug 2013
Location: Adirondacks
Posts: 45
Called Jensen hot line once we got to CG. Tech said to cut all power to monitor for 4 hrs and stressed that 4 hrs was necessary. Did that and it's back up and running this morning.
__________________

__________________
Doree and Neal,
2018 Cardinal 3850 RL Estate

ADK-RVer is offline   Reply With Quote
Old 08-23-2016, 04:55 PM   #3
Senior Member
 
Subsailor's Avatar
 
Join Date: Nov 2015
Location: Pacific Northwest
Posts: 285
Quote:
Originally Posted by ADK-RVer View Post
Called Jensen hot line once we got to CG. Tech said to cut all power to monitor for 4 hrs and stressed that 4 hrs was necessary. Did that and it's back up and running this morning.
Happy to hear you are up and running again. I assume this is some type of master reboot for the system, but did the tech mention what he thought it might be?
__________________
Glenn and Darcy
2018 Berkshire 39A
2016 Jeep Wrangler Unlimited/Blackbear (toad)
Pacific Northwest
Subsailor is offline   Reply With Quote
Old 08-23-2016, 07:57 PM   #4
Member
 
Join Date: Aug 2013
Location: Adirondacks
Posts: 45
This is a common problem with this unit -JRV212T at about the 3 yr mark according to Internet comments. Actually although the monitor came on when we first started up this morning, when we shut down at a rest area monitor was black again on startup. So again we had no cameras. Techs said unit was "frozen" and 4 hr reboot only answer. But apparently not a permanent fix for us. Needs to be replaced. Warranty is only 1 yr. Jensen suggests JRV9000R, which has same dimensions.
__________________
Doree and Neal,
2018 Cardinal 3850 RL Estate

ADK-RVer is offline   Reply With Quote
Old 08-24-2016, 06:12 PM   #5
Senior Member
 
fredhardy's Avatar
 
Join Date: Apr 2014
Location: Phoenix
Posts: 148
Thanks for sharing what the Jensen tech identified as the problem.
__________________
Fred Hardy
Phoenix, AZ
2014 Berkshire 390BH-60
2007 Explorer Sport Trac
fredhardy is offline   Reply With Quote
Reply

Tags
black

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:35 PM.