Reply
 
Thread Tools Display Modes
Old 06-28-2014, 02:39 PM   #1
Senior Member
 
Join Date: Nov 2012
Location: Home is where I park it
Posts: 1,503
Fan Bolts

Tom, I think it was you that had the fan go thru the radiator on your '08??

Are those the bolts that hold on part number 7 in the attached pic?

The pic is specific to my VIN so if those are the bolts that sheared off then I may have the same problem one day, since it appears I only have four bolts.

Thanks

Boowho??
Attached Thumbnails
Click image for larger version

Name:	fan.png
Views:	84
Size:	42.8 KB
ID:	56577  
__________________

__________________
boowho is offline   Reply With Quote
Old 06-28-2014, 10:25 PM   #2
Senior Member
 
Join Date: Nov 2012
Location: Home is where I park it
Posts: 1,503
BTW.......

Also have now figured out that the "gearbox" associated with the cooling fan is for side mounted radiators ONLY.

We don't have that gearbox.

Boowho??
__________________

__________________
boowho is offline   Reply With Quote
Old 06-29-2014, 05:44 PM   #3
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Boo,
My fan did not go through the radiator. I contacted DOT and NY State dept. of Consumer Affairs. They contacted Daimler and were able to convince them to change the fan hub as a safety issue.
Good luck,
Tom
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 06-29-2014, 11:00 PM   #4
Senior Member
 
Join Date: Nov 2012
Location: Home is where I park it
Posts: 1,503
Quote:
Originally Posted by tmmar View Post
Boo,
My fan did not go through the radiator. I contacted DOT and NY State dept. of Consumer Affairs. They contacted Daimler and were able to convince them to change the fan hub as a safety issue.
Good luck,
Tom
So what did FL do to fix your issue? It sure looks like I only have 4 bolts and I think somebody said the "new" one has 5.

Boowho??
__________________
boowho is offline   Reply With Quote
Old 06-30-2014, 04:45 PM   #5
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Boo,
They replaced the 4 bolt hub with a 5 bolt one. When I asked how they could do that they said the 5th hole was already there and they just bolted the new one on. They were able to crawl under neath and and I think they removed the air filter and were able to reach the area and replace the hub.
Tom
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Reply

Tags
fan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:17 AM.