Thread Tools Display Modes
Old 11-15-2015, 08:40 PM   #11
Senior Member
fredhardy's Avatar
Join Date: Apr 2014
Location: Phoenix
Posts: 109
I checked the lens cover for the OEM fog lights I removed and there are no identifying #'s or marks. The lights I installed are heavy duty hi-intensity "off-road" lights that I intend to use for daylight driving only.
Part info: ANZO, 3x3 LED. # 861159 square, approx $100
To all owners: if you climb underneath and look at the installation of the OEM fog lights, the installation studs off the lights only have small star washers and nuts securing the lights. I recommend additional flat washers be added to bear the load of the lights. My lights were pulling the star washers thru the fiberglass.
Regards, Fred

Fred Hardy
Phoenix, AZ
2014 Berkshire 390BH-60
2007 Explorer Sport Trac
fredhardy is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:30 AM.