Reply
 
Thread Tools Display Modes
Old 07-08-2014, 09:48 PM   #11
Senior Member
 
klucas's Avatar
 
Join Date: Sep 2010
Posts: 375
I took the switch off and the fan stopped. I out it back on it clicked then fan came back on. No flame. Does this mean something else is wrong?


Sent from my iPhone using Forest River Forums
__________________

__________________
klucas is offline   Reply With Quote
Old 07-08-2014, 11:02 PM   #12
Senior Member
 
jevanb's Avatar
 
Join Date: Dec 2012
Location: Michigan
Posts: 1,441
You took the switch off??? You should of jumped the ground to the power , that by passes the switch. And will turn on the propane ignition. Call Girard tomorrow they will talk you thru troubleshooting other issues...
__________________

__________________
2012 Wildcat 344QB

06 LBZ ,CC 4x
lots of mods
Superglide
jevanb is offline   Reply With Quote
Old 07-09-2014, 07:46 AM   #13
Senior Member
 
klucas's Avatar
 
Join Date: Sep 2010
Posts: 375
I jumped it first and nothing happened. I will call once they open today. Very frustrating.


Sent from my iPhone using Forest River Forums
__________________
klucas is offline   Reply With Quote
Old 07-09-2014, 11:03 AM   #14
Senior Member
 
klucas's Avatar
 
Join Date: Sep 2010
Posts: 375
Click image for larger version

Name:	ImageUploadedByForest River Forums1404918000.727105.jpg
Views:	217
Size:	777.7 KB
ID:	57710

I just got of the phone with tech support. The white sensor is a over heat switch and reset. I just had to push the button and all is good now. The tech told me it overheated and protected itself by this switch. Apparently in the shower with the mixing valve you can't use any cold water. Hot water only and use the dial to adjust the temp. I hope this info will be useful to someone else one day.



Sent from my iPhone using Forest River Forums
__________________
klucas is offline   Reply With Quote
Old 07-09-2014, 01:10 PM   #15
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Help with tankless. Any ideas?

Klucas
Thanks for the update. It's frustrating when a main utility does not work. Thanks for sharing the fix.


Sent from my iPhone using Forest River Forums
__________________
Phil57 is offline   Reply With Quote
Old 07-09-2014, 05:24 PM   #16
Senior Member
 
Mmnsc's Avatar
 
Join Date: Sep 2012
Location: Charleston County SC
Posts: 563
I have found the overheat safety tends to trip when you change campsites and get air in the system. When you purge the air out make sure the power switch on the heater is off. When the switch is on, you get a temporary spike in water temp that trips the switch thus requiring it to be reset.
__________________
Mmnsc is offline   Reply With Quote
Old 07-09-2014, 05:41 PM   #17
Senior Member
 
klucas's Avatar
 
Join Date: Sep 2010
Posts: 375
Quote:
Originally Posted by Mmnsc View Post
I have found the overheat safety tends to trip when you change campsites and get air in the system. When you purge the air out make sure the power switch on the heater is off. When the switch is on, you get a temporary spike in water temp that trips the switch thus requiring it to be reset.

Great tip. Also good to know that reset is there. Thanks



Sent from my iPhone using Forest River Forums
__________________
klucas is offline   Reply With Quote
Old 07-09-2014, 05:44 PM   #18
Senior Member
 
klucas's Avatar
 
Join Date: Sep 2010
Posts: 375
Quote:
Originally Posted by Phil57 View Post
Klucas
Thanks for the update. It's frustrating when a main utility does not work. Thanks for sharing the fix.


Sent from my iPhone using Forest River Forums

Yes, it is very frustrating. It usually happens at the worst time. Murphy's law. Good to have the fix and hope this easy fix will help others. Also the fact to not use any cold water on the mix valve also. The gen 2 is very different in that regard from the original gen1 we had in our coach at purchase. But this one seems to have much better performance.


Sent from my iPhone using Forest River Forums
__________________
klucas is offline   Reply With Quote
Old 07-12-2014, 06:17 PM   #19
Senior Member
 
jevanb's Avatar
 
Join Date: Dec 2012
Location: Michigan
Posts: 1,441
glad you got it fixed, sorry I did not think of that issue because mine did that same thing once, we just got back in town camping for the last 1.5 weeks and internet no work at most of the places
__________________
2012 Wildcat 344QB

06 LBZ ,CC 4x
lots of mods
Superglide
jevanb is offline   Reply With Quote
Old 07-13-2014, 12:26 AM   #20
Senior Member
 
Mbh818's Avatar
 
Join Date: Apr 2013
Location: East Stroudsburg, PA
Posts: 104
👍


Sent from my iPad using Forest River Forums
__________________

__________________
Mike Hollar
2014 Berkshire 390BH-40
2012 Chevy Equinox - TOAD
Mbh818 is offline   Reply With Quote
Reply

Tags
tank, tankless

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:38 AM.