Thread Tools Display Modes
Old 10-08-2016, 07:04 AM   #1
Senior Member
Join Date: Jan 2014
Posts: 151
Inverter help

Just before I was going to bed last night everything connected to the inverter started to blink on and off. They would stay on for a few seconds then shut off for a few. It was late, and nothing I needed was on that curicut. This morning every thing is the same still blinking. Any body have any idea what's wrong. Jim

jrlebaron is offline   Reply With Quote
Old 10-08-2016, 05:23 PM   #2
Senior Member
Join Date: Jul 2013
Location: Broken Arrow, OK
Posts: 127
Hopefully you already have it fixed. The only thing I can think of is to reset the inverter, button should be on the inverter, if no go, then try turning off breakers for flashing circuits, then call the inverter company.


2015 Charleston 430RB
Billr is offline   Reply With Quote
Old 10-09-2016, 06:31 AM   #3
Site Team - Lou
Herk7769's Avatar
Join Date: Oct 2009
Location: South Eastern PA
Posts: 19,830
Are you on shore power, internal generator, or battery power only?
When the items connected to the inverter go "off", is there a beep (or other voltage alarm) coming from the inverter?

Check for a loose connection at the inverter ...

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
Herk7769 is offline   Reply With Quote
Old 10-10-2016, 08:21 AM   #4
Senior Member
Join Date: Jan 2014
Posts: 151
I'm running on shore power. I've tried a reset hasn't worked. Plan to make a few phone calls today. Thanks for the replies Jim
jrlebaron is offline   Reply With Quote
Old 10-10-2016, 10:52 AM   #5
Join Date: Jan 2012
Location: Riverside, CA
Posts: 26
I had this problem. Long story short, it required a inverter replacement. The computer boards fail over time., and mine got worse failing almost every trip.

Sent from my iPad using Forest River Forums
2008 Berkshire 36SQ, 2012 Honda CRV
Edward972 is offline   Reply With Quote
Old 10-10-2016, 04:42 PM   #6
Join Date: Sep 2014
Location: Monterey, CA
Posts: 84
I had the same issue about a year ago. I also had to replace my inverter. Turns out the internal fan went out. Camping world (horrible experience) had the fan replaced and kept having issues so they replaced the entire inverter. Best of luck!

trekdave42 is offline   Reply With Quote
Old 10-14-2016, 04:27 PM   #7
Senior Member
Join Date: Jan 2014
Posts: 151
After a few phone calls and a few days I finally decided to change out my inverter. Finished that today seems like that did the trick. Jim
jrlebaron is offline   Reply With Quote
Old 10-16-2016, 02:56 PM   #8
Senior Member
Phil57's Avatar
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,756
Jim glad you got it working. Did you use the same inverter or upgrade it?

Phil and Dianna
2011 Berkshire 390 RB
Phil57 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:24 PM.