Reply
 
Thread Tools Display Modes
Old 06-11-2016, 11:42 AM   #21
Senior Member
 
Hallen01's Avatar
 
Join Date: Dec 2010
Posts: 102
I got to put an eyeball ont I-RV's installation, and it's even slicker than it looks in his post. I'm sorry that mine totally quit before this model came out, although the Girard heater Model GSWH-1 (“Gen-1”) I had totally quit, and I had to do something. I therefore installed the newer "dial-type" GSWH-1M (“1M model”), and it works fine - a big improvement.

Sadly, I probably didn't have to replace it after it totally quit, although I tried in vain several times to escape from an assumed heater outlet over-temp lockout, using the escape method documented in the users manual.

After I went to the trouble to install the replacement model, I inadvertently caused an outlet over-temp lockout, from which I again was unable to recover. This time, I called Girard customer service, and they gave me the escape procedure, which is undocumented. With the heater off, press the black button in the center of the white, cylindrical plastic "ECO valve in the outlet water line, just to the left of the heater box. Then turn the unit on.
Attached Thumbnails
Click image for larger version

Name:	Daisy Bus Heater ECO Valve Reset Button.jpg
Views:	112
Size:	246.1 KB
ID:	110792  
__________________

__________________
Hallen01 is offline   Reply With Quote
Old 06-19-2016, 03:49 AM   #22
Junior Member
 
Join Date: Jun 2016
Posts: 2
Girard GSWH-2 Install

Hi, new to the forum. This week I installed my new GSWH-2. After verifying electrical red and black connected correctly, no water leaks and no propane leaks I powered it up. Remote display shows temp but no other icons. Water not heating. Opened cover, green light on main board. No error codes but no sound from the blower motor. I read on earlier models that there was a ECO valve that could be depressed to reset the unit. However, I do not see one on this model. Any ideas on how to get her fired up?
__________________

__________________
tdogrv is offline   Reply With Quote
Old 06-19-2016, 07:32 AM   #23
Senior Member
 
DouglasReid's Avatar
 
Join Date: Jun 2016
Location: Maurice, LA
Posts: 1,088
Hinged on left is good for me

Quote:
Originally Posted by Subsailor View Post
It would have been nice if they made that door hinged on the right instead of the left. I always worry about a latch failing or not be shut all the way and when doors are hinged on the left and come open while going down the highway, probably gone. One of my travel checks is to go around and pull on every outside door. -Glenn
My WH is on the left side of my camper. Hinged on the left would keep the door closed if the latch failed. It just depends on which side your WH is mounted. I can't see them making teo models, but a reversible door might be an option for when a Gen4 model appears
__________________
DouglasReid is offline   Reply With Quote
Old 06-19-2016, 08:15 AM   #24
Senior Member
 
I-RV's Avatar
 
Join Date: Jun 2013
Location: Mount Laurel, NJ
Posts: 1,022
Quote:
Originally Posted by tdogrv View Post
Hi, new to the forum. This week I installed my new GSWH-2. After verifying electrical red and black connected correctly, no water leaks and no propane leaks I powered it up. Remote display shows temp but no other icons. Water not heating. Opened cover, green light on main board. No error codes but no sound from the blower motor. I read on earlier models that there was a ECO valve that could be depressed to reset the unit. However, I do not see one on this model. Any ideas on how to get her fired up?
The water heater has a valve located on the back of the unit. Make sure that it is open.
Hank
__________________
Gale & Hank- 2012 Berkshire 390BH
I-RV is offline   Reply With Quote
Old 06-23-2016, 07:33 PM   #25
Junior Member
 
Join Date: Jun 2016
Posts: 2
Quote:
Originally Posted by I-RV View Post
The water heater has a valve located on the back of the unit. Make sure that it is open.
Hank
Hank - thanks! It is open. Any other thoughts?
__________________
tdogrv is offline   Reply With Quote
Old 06-26-2016, 10:20 AM   #26
Junior Member
 
Join Date: Dec 2015
Posts: 17
Quote:
Originally Posted by I-RV View Post
I previously had the Girard Gen I (GSWH-1) Thank-Less water heater, which was a pain! I installed by myself the Gen III (GSWH-2) about a month ago and have since tried it out on a trip to St. Augustine and then to the 1000 Islands. It works like a water heater should; just set the desired temperature and if too hot, cold water may be mixed in or the temperature can be lowered. It is awesome!!!

The following current thread also makes mention by some Gen III users:

Hot water heater or lack there of

I suggest that other Gen III users post their evaluations here to give all the Berk Gen I & II users a vote of confidence should they consider making the change..

Here are some pics of my installation:
My tankless water heater is not heating. It has in the past. We are new to the motor home business. Suggestions that might get this issue resolved.

How does one get the gas fired water heater to come on? Do you have to turn off the electricity?

We have a 2016 Berkshire 34 SQ model.

All suggestions appreciated.
__________________
dhornback is offline   Reply With Quote
Old 06-26-2016, 10:51 AM   #27
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Quote:
Originally Posted by dhornback View Post
My tankless water heater is not heating. It has in the past. We are new to the motor home business. Suggestions that might get this issue resolved.



How does one get the gas fired water heater to come on? Do you have to turn off the electricity?



We have a 2016 Berkshire 34 SQ model.



All suggestions appreciated.

I did answer on the other thread. So you know the Atwood WH is LP only no electric option.
__________________
Phil57 is offline   Reply With Quote
Old 06-26-2016, 04:22 PM   #28
Junior Member
 
Join Date: Dec 2015
Posts: 17
Quote:
Originally Posted by Hallen01 View Post
I got to put an eyeball ont I-RV's installation, and it's even slicker than it looks in his post. I'm sorry that mine totally quit before this model came out, although the Girard heater Model GSWH-1 (“Gen-1”) I had totally quit, and I had to do something. I therefore installed the newer "dial-type" GSWH-1M (“1M model”), and it works fine - a big improvement.

Sadly, I probably didn't have to replace it after it totally quit, although I tried in vain several times to escape from an assumed heater outlet over-temp lockout, using the escape method documented in the users manual.

After I went to the trouble to install the replacement model, I inadvertently caused an outlet over-temp lockout, from which I again was unable to recover. This time, I called Girard customer service, and they gave me the escape procedure, which is undocumented. With the heater off, press the black button in the center of the white, cylindrical plastic "ECO valve in the outlet water line, just to the left of the heater box. Then turn the unit on.
Thank you for the photo. I have a similar button on my unit. I pressed the button when the switch was off on the inside. Returned to the inside and turned the water heater switch on and checked. Still not hot water from either the tankless or propane water heater.

Are the tankless and the propane heater two separate hot water heaters? Is one electric and the other one propane?

As in your photo I see the copper tank and hear water running through it but the unit never comes on. Education and suggestions welcomed.

Thanks in advance.
__________________
dhornback is offline   Reply With Quote
Old 06-26-2016, 07:23 PM   #29
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
You have one water heater. It's an Atwood brand and only runs on LP. There is no electric element on it. It does not run on anything but LP.
__________________
Phil57 is offline   Reply With Quote
Old 07-08-2016, 03:59 PM   #30
Junior Member
 
Join Date: May 2016
Location: Edmond, OK
Posts: 3
Quote:
Originally Posted by dhornback View Post
Thank you for the photo. I have a similar button on my unit. I pressed the button when the switch was off on the inside. Returned to the inside and turned the water heater switch on and checked. Still not hot water from either the tankless or propane water heater.

Are the tankless and the propane heater two separate hot water heaters? Is one electric and the other one propane?

As in your photo I see the copper tank and hear water running through it but the unit never comes on. Education and suggestions welcomed.

Thanks in advance.
We also have a 2016 Berkshire 34QS and are having trouble getting hot water. Sounds like you are saying you turn off the switch inside the MH and then go to the outside access panel near the passenger rear and press a black button and then turn the heater back on inside. Not getting any help from our dealer and getting frustrated as we need hot water for my elderly parents.
__________________

__________________
Bill - Berkshire 34QS
u30363 is offline   Reply With Quote
Reply

Tags
heater, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:43 AM.