Reply
 
Thread Tools Display Modes
Old 10-13-2014, 09:35 AM   #1
Senior Member
 
Join Date: Feb 2014
Location: South Carolina
Posts: 195
Marker Lights Out

Having an issue with my marker lights, clearance lights and tail lights not working. My headlights work and the break lights are fine. I went to Freightliner over the weekend and picked up a new relay but they did not have the "special" freightliner 30amp fuse needed. Replaced the relay and borrowed a similar 30amp fuse to problem shoot. Nothing has worked yet. I'm working on the top black fuse panel in the front drivers cargo bay. My RV is a 2014 390bh. Any other ideas r suggestions would be greatly appreciated before I bring it into the dealership. As a side note, I never thought it would be so hard to pick up some simple fuses


Sent from my iPhone using Forest River Forums
__________________

CT Camper is offline   Reply With Quote
Old 10-13-2014, 02:20 PM   #2
Senior Member
 
edgewant's Avatar
 
Join Date: Feb 2013
Location: Tennessee
Posts: 537
I had issues with my dash fan. It was intermittent. Turned out to be a bad splice. I located it under the removal portion of the dash. Could be a similar issue you're having.
__________________
edgewant

2013 Berkshire 390RB-60
toad - 2002 Jeep Wrangler Sport
edgewant is offline   Reply With Quote
Reply

Tags
light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:17 AM.


×