Reply
 
Thread Tools Display Modes
Old 01-25-2011, 12:53 PM   #1
Member
 
RoamingEngineer's Avatar
 
Join Date: Jun 2010
Location: Florida
Posts: 76
Moisture in side camera (cameras dead)

My right turn signal camera stopped working and has visible moisture behind the lens.

I called my dealer (Lazydays) and they said the warranty claim was denied because they couldn't prove why it failed.

They also couldn't tell me who "they" were. I'm not sure if Lazydays went through Forest River warranty or the camera manufacturers warranty.

Anyone had any problems with their camera and was it handled through warranty?
__________________

__________________
RoamingEngineer is offline   Reply With Quote
Old 01-25-2011, 01:10 PM   #2
Senior Member
 
Join Date: Dec 2010
Posts: 517
Send a message via Skype™ to scubieman
Don't stop till you find out who they went through.

I heard a similar story once but they never called for warranty check.
__________________

__________________
2009 Dodge Ram Mega Cab 2500 6.7 cummins
2011 Forest River Cherokee 28BHKS

scubieman is offline   Reply With Quote
Old 01-25-2011, 01:31 PM   #3
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
I have the same problem with my side view cameras. They are ASA cameras and were replaced a couple of times by ASA and I still have the same problem. They say they are waterproof but I don't see how they could be because I will still get condensation behind the lens.
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 01-25-2011, 01:49 PM   #4
Member
 
RoamingEngineer's Avatar
 
Join Date: Jun 2010
Location: Florida
Posts: 76
Did you go through the dealer to get them replaced?
__________________
RoamingEngineer is offline   Reply With Quote
Old 01-25-2011, 05:12 PM   #5
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
No- I dealt directly to ASA. I'm not sure if your cameras are the same manufacturer as the ones on my rig, but as I said in my earlier post, they were replaced more than once and I still have the problem. It doesn't even have to be raining. If it is cool over night and then warm during the day, I will get condensation. Not sure how to eliminate the problem.
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 01-25-2011, 05:26 PM   #6
Member
 
RoamingEngineer's Avatar
 
Join Date: Jun 2010
Location: Florida
Posts: 76
Interesting. The first thing I tried was contacting ASA (Voyager) and they said I had to go through my dealer. They claimed they didn't work directly with end users on warranty issues.
__________________
RoamingEngineer is offline   Reply With Quote
Old 01-25-2011, 06:33 PM   #7
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
I told them that it was an 8 hour trip to my dealer (which is true) and that if they sent the cameras to me, I would install them and they would save the labor charges on the installation.
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 01-26-2011, 07:17 AM   #8
Junior Member
 
Smithgirl3's Avatar
 
Join Date: Jan 2011
Posts: 6
My cameras are the same way, 2009 Berkshire.
__________________
Smithgirl3 is offline   Reply With Quote
Old 01-26-2011, 11:33 AM   #9
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Well, I guess from all the postings here ASA has a bigger problem with their cameras than they are admitting to. Don't know what can be done about it though.
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 01-26-2011, 11:38 AM   #10
Member
 
RoamingEngineer's Avatar
 
Join Date: Jun 2010
Location: Florida
Posts: 76
I would think a company like Forest River would have some pull with them. A bunch of end users like us complaining are easy to brush under the rug individually. I would think that if we all complained to FR and made a big stink, FR would go after ASA on our behalf.

I wonder if this is a design flaw or just a bad batch that made it out the door. What's interesting is that I've only had this problem on 1 camera. The camera on the other side has zero moisture and works fine.
__________________

__________________
RoamingEngineer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:12 PM.