Reply
 
Thread Tools Display Modes
Old 06-15-2016, 09:49 AM   #1
Senior Member
 
Join Date: Jan 2014
Posts: 155
Need electrical help

I must a loose ground on the dash components. I'll be driving down the road all of a sudden the dash air shuts down, radio, fans, seat, wipers, mirrors, all shut down. Anyone have any idea what's causing this? I called FL they said it's the manufacturer have a call in with FR no response as of yet. I figure someone here might be able to steer me in the right direction. Thanks for any help Jim
__________________

__________________
jrlebaron is offline   Reply With Quote
Old 06-15-2016, 11:58 AM   #2
Senior Member
 
accumack's Avatar
 
Join Date: Sep 2011
Posts: 522
I would check the plug connections One of the connectors is probably loose under the dash or in the generator compartment on the firewall.
__________________

__________________
2011 Berkshire 390-rb-40, upgraded tires and front axle airbags, 2012 Jeep Wrangler 2 door, Blue Ox baseplate and BlueOx aladdin tow bar, Blue Ox Patriot brake system, wiring run through right frame rail and homemade led taillight bar.FB.
Ham KG5LTL.
accumack is offline   Reply With Quote
Old 06-15-2016, 08:10 PM   #3
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Quote:
Originally Posted by jrlebaron View Post
I must a loose ground on the dash components. I'll be driving down the road all of a sudden the dash air shuts down, radio, fans, seat, wipers, mirrors, all shut down. Anyone have any idea what's causing this? I called FL they said it's the manufacturer have a call in with FR no response as of yet. I figure someone here might be able to steer me in the right direction. Thanks for any help Jim

Jim this has come up a couple of times. If I remember correctly Craig had this issue. Try doing a search. I'm on my phone or I would do it. Sorry bud I don't remember the fix but I think the ignition was bad.
__________________
Phil57 is offline   Reply With Quote
Old 06-16-2016, 03:51 PM   #4
Senior Member
 
edgewant's Avatar
 
Join Date: Feb 2013
Location: Tennessee
Posts: 456
Had an issue with dash fan arbitrarily cutting out. Turned out to be a bad splice in the bundle near the back of the radio.


Sent from my iPhone using Forest River Forums

2013 Berkshire 390RB-60
Toad: 2002 Jeep Wrangler
__________________
edgewant

2013 Berkshire 390RB-60
toad - 2002 Jeep Wrangler Sport
edgewant is offline   Reply With Quote
Old 06-17-2016, 09:32 AM   #5
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Quote:
Originally Posted by edgewant View Post
Had an issue with dash fan arbitrarily cutting out. Turned out to be a bad splice in the bundle near the back of the radio.


Sent from my iPhone using Forest River Forums

2013 Berkshire 390RB-60
Toad: 2002 Jeep Wrangler
I had the exact same issue with my coach. I guess the same guy that wired yours did mine (LOL!!).
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Reply

Tags
electric, electrical

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:06 PM.