Reply
 
Thread Tools Display Modes
Old 11-07-2012, 06:46 PM   #1
Member
 
Join Date: Jul 2012
Posts: 42
Popping Noise

I recently purchased a 2012 Berkshire 360-FWS. I have the freightliner XC raised rail chassis, with Equalizer System levelers. When I put the levelers down, the air system automatically dumps the air as the levelors extend. All goes well, however, after 1-2 days, I start to hear a popping noise every now and then. I think it is the air bags that seem to make a popping noise. Not sure why. Does anyone else have this issue? There really is only two things it could be, the air bags or the levelers. This popping sound does not happen when the coach is just parked, levelers up and air still in the system. Any thoughts?
__________________

__________________
2012 Berkshire 360-FWS
2003 Jeep Liberty Dinghy
Roadmaster All-Terrain
BrakeBuddy
hawk10eye is offline   Reply With Quote
Old 11-07-2012, 10:48 PM   #2
Junior Member
 
wm1964's Avatar
 
Join Date: Aug 2012
Location: South Jersey
Posts: 22
hawk10eye,

We have the same unit. I have not noticed any popping noise when setting up the unit, but when we retract the jacks and the bags are filling back up it pops several times as it comes back to the normal ride pressure. It is fairly loud.
__________________

__________________
2012 360 FWS
wm1964 is offline   Reply With Quote
Old 11-08-2012, 08:17 AM   #3
Senior Member
 
Join Date: Sep 2012
Posts: 188
It is likely just a bit of system "creep" from the hydraulic levelers. It is likely nothing of real concern however it would be good to check the hydraulic lines to each jack as well as the fittings on the hydraulic pump to ensure they aren't leaking, which would cause a slight loss of pressure in the system, allowing the jacks to make a popping noise as they "creep" down.
The popping noise should have nothing to do with your airbags in the situation you describe.

James
__________________
speedmerchant is offline   Reply With Quote
Old 11-08-2012, 09:48 AM   #4
Member
 
Join Date: Jul 2012
Posts: 42
Thanks for the replies. I think creep from the levelers may be the issue. I have checked and I do not see any hydraulic leaks or spots on any parking pad after staying there for a while. I did add a quart of fluid a week ago, and I think the noise occurrs less. I will check that again. Appreciate the feedback.
__________________
2012 Berkshire 360-FWS
2003 Jeep Liberty Dinghy
Roadmaster All-Terrain
BrakeBuddy
hawk10eye is offline   Reply With Quote
Old 11-08-2012, 07:11 PM   #5
Senior Member
 
accumack's Avatar
 
Join Date: Sep 2011
Posts: 522
We have the same same noise. It is the levelers it seems to happen more with temperature changes. It causes no problems even when we are at a park for a month.
__________________
accumack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:50 PM.