Reply
 
Thread Tools Display Modes
Old 01-25-2016, 04:39 PM   #11
Senior Member
 
mikeborny's Avatar
 
Join Date: Jun 2015
Posts: 155
It started up without a problem, but low coolant light came on. Then after a minute or two, the shut engine down light came on and I shut it down. In the 40's all day and tomorrow so going to add some coolant and check tomorrow.


Mike & Amy + 3 and the dogs!
2014 berkshire 390bh-40
__________________

__________________
mikeborny is offline   Reply With Quote
Old 01-25-2016, 04:47 PM   #12
Senior Member
 
accumack's Avatar
 
Join Date: Sep 2011
Posts: 519
Is your engine block heater plugged in?
__________________

__________________
2011 Berkshire 390-rb-40, upgraded tires and front axle airbags, 2012 Jeep Wrangler 2 door, Blue Ox baseplate and BlueOx aladdin tow bar, Blue Ox Patriot brake system, wiring run through right frame rail and homemade led taillight bar.FB.
Ham KG5LTL.
accumack is offline   Reply With Quote
Old 01-25-2016, 04:49 PM   #13
Senior Member
 
Join Date: Feb 2015
Posts: 741
1-800-FTL-HELP then #1 when prompted.
__________________
Paulie Boy is offline   Reply With Quote
Old 01-25-2016, 05:12 PM   #14
Junior Member
 
Join Date: Dec 2014
Location: Whitehorse Yukon
Posts: 14
Quote:
Originally Posted by Kenny kustom View Post
Get it into a warm shop asap.

Then you can see if anything has been damaged by the coolant freezing. Just let it thaw, check for leaks.

Did it start? I wouldn't try starting it with a frozen block.


2016 Sabre 36QBOK
2015 Ram 3500 CUMMINS
I agree if the coolant is frozen in the surge tank than good chance it is also froze in the block & head. Hopefully it has only pushed out a frost plug & not cracked anything. I don't recommend starting it if frozen. Get to a warm shop & check for leaks.
__________________
Gee Force is offline   Reply With Quote
Old 01-25-2016, 06:54 PM   #15
Senior Member
 
Kenny kustom's Avatar
 
Join Date: Sep 2015
Posts: 2,196
Quote:
Originally Posted by mikeborny View Post
It started up without a problem, but low coolant light came on. Then after a minute or two, the shut engine down light came on and I shut it down. In the 40's all day and tomorrow so going to add some coolant and check tomorrow.


Mike & Amy + 3 and the dogs!
2014 berkshire 390bh-40


Did it not leave the factory with the proper mixture of antifreeze?

I'm wondering how it froze?


2016 Sabre 36QBOK
2015 Ram 3500 CUMMINS
__________________
Kenny kustom is offline   Reply With Quote
Old 01-25-2016, 07:00 PM   #16
Senior Member
 
mikeborny's Avatar
 
Join Date: Jun 2015
Posts: 155
Good news is that the overflow was not frozen, just very low. Put gallon and a half of coolant in and plugged in block heater while gen was running for about 40 min. It took that long to get that damn cap off. How do you have the engine "high" idle?


Mike & Amy + 3 and the dogs!
2014 berkshire 390bh-40
__________________
mikeborny is offline   Reply With Quote
Old 01-25-2016, 07:02 PM   #17
Senior Member
 
Kenny kustom's Avatar
 
Join Date: Sep 2015
Posts: 2,196
Quote:
Originally Posted by mikeborny View Post
Good news is that the overflow was not frozen, just very low. Put gallon and a half of coolant in and plugged in block heater while gen was running for about 40 min. It took that long to get that damn cap off. How do you have the engine "high" idle?


Mike & Amy + 3 and the dogs!
2014 berkshire 390bh-40

Good to hear!




2016 Sabre 36QBOK
2015 Ram 3500 CUMMINS
__________________
Kenny kustom is offline   Reply With Quote
Old 01-25-2016, 07:14 PM   #18
Senior Member
 
mikeborny's Avatar
 
Join Date: Jun 2015
Posts: 155
Thanks for search, i was able to figure out you can high idle by using cruise control. Wanted to let engine heat up to see if i can notice any leaking from radiator.


Mike & Amy + 3 and the dogs!
2014 berkshire 390bh-40
__________________
mikeborny is offline   Reply With Quote
Old 01-25-2016, 07:23 PM   #19
Senior Member
 
Join Date: Aug 2015
Location: Danbury, Ct.
Posts: 642
Good news Mike.
__________________
Joe & Lori

2014 Berkshire 390 RB-40
5456Mich is offline   Reply With Quote
Old 01-25-2016, 07:47 PM   #20
Senior Member
 
Join Date: Feb 2015
Posts: 741
Quote:
Originally Posted by mikeborny View Post
Thanks for search, i was able to figure out you can high idle by using cruise control. Wanted to let engine heat up to see if i can notice any leaking from radiator.


Mike & Amy + 3 and the dogs!
2014 berkshire 390bh-40

Rock on!


Paul
2014 390 BH-60
2015 Jeep Wrangler Unltd. Sahara
Sent from my iPad using Forest River Forums
__________________

__________________
Paulie Boy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:09 AM.