Reply
 
Thread Tools Display Modes
Old 10-01-2012, 03:05 PM   #111
Senior Member
 
Join Date: Oct 2011
Location: Alberta Canada
Posts: 417
We have a 2012 Berkshire 390BH-60 that was manufatured in 2011. Needless to say I was rather concerned when I saw this post. The type of Transfer switch that I have in my unit is the same one that KLUKAS shows in one of his posts. It is a silver metal box Model PD58 made by Progressive Dynamics.

I have just confirmed by way of a telephone conversation with William Convay at Forest River that this type of transfer switch is not included in the recall even though it fall within the date range. He told me that they stopped using the effected units in 2010 (manufacture date not model date).
__________________

__________________
lefaivre is offline   Reply With Quote
Old 10-01-2012, 03:38 PM   #112
2011 Berkshire 390BH
 
Superchief's Avatar
 
Join Date: Aug 2011
Location: Lancaster, NY
Posts: 1,063
Tom,

Spent the last four days in the coach. No hum from the transfer switch. Getting some hum from the inverter, but nothing I hear inside the coach. Thought I might have an issue with the transfer switch this past weekend when I dry camped in a rest area on my way to Purdue Univ.. Started the generator to make coffee, the heat pump went on, and the batteries started to charge. Noticed that the coffee maker was no longer on. First time this has ever happen. Thought I pop a fuse. Checked the AC fuse box under the bed and found everything okay. Reset all of the plugs, nothing. Went out and hit the transfer switch cover a few times, nothing. Checked the DC fuses, nothing. Turned off the generator and restarted it, nothing. As a last resort, check the generator for a fuse switch. Yes that was it!! Finally got my coffee! That issue has probably been posted here a hundred times, but I read so many of these posts that it must have been somewhere in the back of my mind. Need to make s trouble shooting guide to cover these issues, or better yet, check this forum before proceeding. But with no coffee, had to think clearly. ;-)
__________________

__________________
Craig



Finally completed all State visits in August 2011 with a trip to North Dakota.
Superchief is offline   Reply With Quote
Old 10-01-2012, 05:29 PM   #113
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Craig,
No coffee! I would have been in a pancic! LOL! Glad to hear that everything is working as it should and you found the problem in time to get the coffee going. Heading out next week to Hershey dar show so I'll get a chance to check everything out a little more fully.
Tom
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 10-15-2012, 10:35 AM   #114
Senior Member
 
Join Date: Sep 2012
Posts: 188
Had trasfer switch changed out the other day. Will send pictures when I get a chance. Looks like they drilled another hole in the replacement box so that all the wires could reach in through the top like the old one. Haven't checked the quality of the job yet as I ended up leaving it there as I had an issue that may be related to the transfer switch changeout. After they changed it out I was checking to make sure everything was good and I noticed that the Magnum inverter display inside the coach had a flashing red "fault" light. We plugged the coach into A/C and the fault eventually cleared and the green inverter light came on. However while plugged in it would not read "a/c in" or indicate any status as to "float, bulk, absorb" Anybody got any ideas? The coach batteries were pretty much dead when I went to pick it up as I think they didn't hit the disconnect button before it sat there a few days before they got to work on it.
Everything else appears to be working as it should other than this. The coach is itself is swithcing over to A/C power as the firdge and microwave switch over fine but the batteries are not being charged now.

James
__________________
speedmerchant is offline   Reply With Quote
Old 10-16-2012, 12:58 PM   #115
Senior Member
 
Join Date: Sep 2012
Posts: 188
Crisis solved. The dealer must have not have shut something off when they did the transfer switch. Anyway it tripped the breakers under the bed and the one on the converter they told me. Everything good now. For the record the new transfer switch does have a hum to it.

Pictures of install attached. As I mentioned in a previous post they drilled another hole in the one side and went in through the top. Install looks ok to me........
Attached Files
File Type: pdf IMG-20121016-00183.pdf (1.92 MB, 41 views)
File Type: pdf IMG-20121016-00185.pdf (1.62 MB, 31 views)
File Type: pdf IMG-20121016-00184.pdf (2.40 MB, 26 views)
__________________
speedmerchant is offline   Reply With Quote
Old 10-16-2012, 01:49 PM   #116
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Had a local electrician do the work and they did basically the same installation. They turned the switch so that the shore line and generator line position didn't change and came in at the top and re-routed the line to the breaker panel (just pulled it out of the hole where it came into the power cabinet and drilled a new hole a little lower and fed the line in through that hole). Worked out well.
Attached Thumbnails
Click image for larger version

Name:	PA161625.jpg
Views:	92
Size:	50.1 KB
ID:	20770  
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 10-13-2013, 04:42 AM   #117
Future Berkshire Owner
 
Joker's Avatar
 
Join Date: Mar 2011
Location: Colorado
Posts: 193
Quote:
Originally Posted by klucas View Post
Here are some photos of mine. It looks like mine is a little different. It is in a metal box. All the wires look ok. What do you guys think?
Yours looks identical to how mine was. My transfer switch recently failed -- it would not switch to shore power. So I decided to replace it. As I was reading the instructions for the install, I saw where the problem may be...FR had mounted the switch in an unapproved orientation.

Notice how the sticker on the outside of the box is sideways? If you rotate the assembly clockwise 90 degrees, it will be in the switch manufacturer's recommended position. In fact the current orientation has a big circle with a line through it on the instructions!

Anyway, there are probably more of us out there with that situation and if anyone is going to install a hardware surge suppressor (as I did concurrently with this repair), it might be a good idea to fix that problem. I'm not sure if it's a safety issue or just a switch longevity or function issue.
__________________
Joker is offline   Reply With Quote
Old 10-13-2013, 04:53 AM   #118
Future Berkshire Owner
 
Joker's Avatar
 
Join Date: Mar 2011
Location: Colorado
Posts: 193
Quote:
Originally Posted by tmmar View Post
Had a local electrician do the work and they did basically the same installation. They turned the switch so that the shore line and generator line position didn't change and came in at the top and re-routed the line to the breaker panel (just pulled it out of the hole where it came into the power cabinet and drilled a new hole a little lower and fed the line in through that hole). Worked out well.
On the new hole they made...did they seal it up with silicone or something? Two reasons...you don't want ant moisture or bugs getting in there and causing electrical problems and also that switch is not an ignition protected switch, which I think means it can spark when it switches and would ignite any flammable materials...fuel vapors, propane fumes, hydrogen from batteries, etc.

With my install, I plugged the old self-tapping screw holes with silicone and also siliconed off the exit area from the load line's conduit. It could carry fumes into that chamber just as well as it carries the wires in!
__________________
Joker is offline   Reply With Quote
Old 10-16-2013, 06:29 PM   #119
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
I don't recall if they sealed it with silicone. They did put a plate over the hole where the wire came in to the cabinet for the old switch.
__________________

__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:20 AM.