Reply
 
Thread Tools Display Modes
Old 06-23-2014, 05:01 PM   #1
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Transfer Switch

Does anyone know who makes the transfer switch that is in our coaches? I need to call them and ask a question.

Also, has anyone else noticed this issue? When I plug my coach in, after a short time the transfer switch kicks in with a clunk noise. Today I was out working on my coach and I heard that same noise once or twice more. Nothing changed with the power to the coach and my Progressive surge suppressor did not note any unusual condition with the power.

Anyone have any ideas?

Thanks,

Tom
__________________

__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is online now   Reply With Quote
Old 06-23-2014, 07:42 PM   #2
Senior Member
 
Mmnsc's Avatar
 
Join Date: Sep 2012
Location: Charleston County SC
Posts: 563
Tom
I notice a clunk also everytime when I first power up. Never noticed it again and nothing seems to change.
I think it is the solenoid kicking in.
Marty
__________________

__________________
Mmnsc is online now   Reply With Quote
Old 06-23-2014, 09:01 PM   #3
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
I always hear it when plugging it in. Funny thing I woke up around 3am and heard the same clunk. I got up thinking I lost power but found nothing. Not sure what to think everything works fine.


Sent from my iPhone using Forest River Forums
__________________
Phil57 is offline   Reply With Quote
Old 06-23-2014, 10:05 PM   #4
Berkshire 390QS
 
NO3putt's Avatar
 
Join Date: Feb 2011
Location: Pueblo Colorado
Posts: 1,251
Mine clunks everytime we plug in. Also have heard it at night, or even durning the day, but always check the microwave clock and each time we lost power and no error codes on the EMS.
__________________
2011: 54 days, 2012: 218 days, 2013: 175 days, 2014: 196 days
2015: 188 days, 2016: 72 days, 2017: 185
2009 Berkshire, 390QS, and toad
Skip
NO3putt is offline   Reply With Quote
Old 06-23-2014, 11:31 PM   #5
Senior Member
 
Campin Cajun's Avatar
 
Join Date: Mar 2013
Location: Cut Off, La.
Posts: 1,830
Mine clunks too.


2013 Berkshire 390 BH
__________________
2013 Berkshire 390BH
Campin Cajun is offline   Reply With Quote
Old 06-24-2014, 08:42 AM   #6
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
I guess that the intermittent 'clunking' noise is a normal condition. I too check the microwave and the surge suppressor and both are normal and everything works fine.
I guess it is just one of those mystery noises that will go unsolved! Hopefully it won't develop into something more serious later on.
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is online now   Reply With Quote
Old 06-24-2014, 04:14 PM   #7
2011 Berkshire 390BH
 
Superchief's Avatar
 
Join Date: Aug 2011
Location: Lancaster, NY
Posts: 1,063
Tom, As you know, the transfer switch is in an aluminum box. When they replaced mine on the recall a couple of tears (years) ago, I noticed the same switch noise. I would think it is suppose to make a "switching noise", as it is mechanical. Put you ear to a light switch in your house, you will hear a noise, but not as loud. Craig


Sent from my iPad using Forest River Forums
__________________
Craig



Finally completed all State visits in August 2011 with a trip to North Dakota.
Superchief is offline   Reply With Quote
Old 06-24-2014, 07:12 PM   #8
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Craig why do they do that after being plugged in for days. No loss if power but get the same bang as I do when I plug in?


Sent from my iPhone using Forest River Forums
__________________
Phil57 is offline   Reply With Quote
Old 06-24-2014, 07:28 PM   #9
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Craig,
As Phil said, when I first plug in I get the clunk. But, it also intermittently clunks while plugged in and just sitting. Nothing changes- power stays on (checked microwave and it is not blinking) and my Progressive shows no issues with the incoming power. Everything seems to be functioning properly.
I guess the coaches may be haunted(LOL!!)
Tom
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is online now   Reply With Quote
Old 06-24-2014, 07:30 PM   #10
Senior Member
 
Campin Cajun's Avatar
 
Join Date: Mar 2013
Location: Cut Off, La.
Posts: 1,830
I have never heard mine RE clunk. Just the initial clunk when I plug into shore power.


2013 Berkshire 390 BH
__________________

__________________
2013 Berkshire 390BH
Campin Cajun is offline   Reply With Quote
Reply

Tags
transfer switch

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:02 PM.