Reply
 
Thread Tools Display Modes
Old 06-23-2015, 07:45 PM   #1
Senior Member
 
Mmnsc's Avatar
 
Join Date: Sep 2012
Location: Charleston County SC
Posts: 563
Windshield wiper arm

Does anyone know the model number and manufacturer of the wiper arm on a 2012 Berkshire? We are in Maine with lots of rain and the drivers side arm broke. Tried to reair but not repairable. Stopped at Autozone but they could not match it up. Will try NAPA tomorrow.


Sent from my iPhone using Forest River Forums
__________________

__________________
Mmnsc is offline   Reply With Quote
Old 06-23-2015, 08:24 PM   #2
Senior Member
 
accumack's Avatar
 
Join Date: Sep 2011
Posts: 522
Quick fix take the passenger side and move to the driver side.
__________________

__________________
accumack is offline   Reply With Quote
Old 06-23-2015, 10:18 PM   #3
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
I had to run through the rain a couple of days like that. Not a big deal. Finding that arm might be tough. Did you call Andy? Good luck sounds like you are having more than your share of problems.
__________________
Phil57 is offline   Reply With Quote
Old 06-24-2015, 08:45 AM   #4
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Marty,
If you can't find one, as Phil said, give Andy a call and maybe they can overnight one to you. Did you resolve your leveling jack issue? Hope everything calms down after this and you can enjoy the rest of your trip. Say hello to Donna.
Tom
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is online now   Reply With Quote
Old 06-24-2015, 09:01 AM   #5
Senior Member
 
Join Date: Mar 2015
Location: Fort White, FL
Posts: 203
As others mentioned, if the passenger arm will work, move it over, if not rain-x the heck out of the windshield.
__________________
foretm is offline   Reply With Quote
Old 06-24-2015, 01:28 PM   #6
Senior Member
 
Mmnsc's Avatar
 
Join Date: Sep 2012
Location: Charleston County SC
Posts: 563
Update
NAPA was no help. Without a part number they could not identify plus they do not have any listings for motorhomes. Did some work om the old one by drilling some holes and putting screws in it to keep the end portion from sliding but to the base while under spring tension. Seems to be holding fine and working well. Look for a new one once back into cuvilization.


Sent from my iPhone using Forest River Forums
__________________

__________________
Mmnsc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:09 PM.