Thread Tools Display Modes
Old 06-10-2016, 06:04 PM   #1
Junior Member
Join Date: May 2016
Posts: 2
50" Legend TV

We have a 2016 Sanibel with a 50" Legend tv in the living room. Turns on fine but after a few minutes the screen goes black and we only have sound. We have gone through all the settings on the tv and turned off anything that might make it go to "sleep". Has anyone else had this problem? Thanks!!

Theclarks89 is offline   Reply With Quote
Old 06-10-2016, 06:16 PM   #2
sammonilla's Avatar
Join Date: May 2014
Location: Woodinville WA
Posts: 92
Sorry to say but it sounds like a bad TV. It has internal thermal protection that is failing and causes the screen to turn off. Sounds like it is time for a new TV!
Scott Sammons
Woodinville Wa
2008 GMC 2500HD Duramax
2012 280BH Casscade
sammonilla is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:23 AM.