Reply
 
Thread Tools Display Modes
Old 06-07-2016, 09:02 AM   #1
Senior Member
 
Join Date: Apr 2016
Location: Cedar Creek Lake, TX
Posts: 1,229
A/C short cycling

Dometic 13,500 a/c and thermostat. 2nd owner so no warranty.

Unit powers up, blows a minute or so, then shuts down for a few seconds. It then powers up again and cools properly. Sometimes does this 2 or 3 times before settling in. Is this normal? If not is the problem in the thermostat or a/c unit?

Thanks!
__________________

__________________
Cedar Creek Lake, Texas
2017 Wildwood 27 RLSS
2016 Ram 5.7L crewcab, 8 speed transmission
CedarCreekWoody is offline   Reply With Quote
Old 06-07-2016, 09:26 AM   #2
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 5,570
If you are starting initially in a hot humid TT and have a ducted unit, the coils can sometimes freeze up because there is not enough air flow. Try opening the quick cool dump vent( slide vent on the bottom of th unit itself). Allow the unit to run a while with vent open to remove heat and humidity. Once the TT cools down some, you can close ( or partially close the vent). it could also be caused by low freon levels, but try the vent trick first.
__________________

__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is online now   Reply With Quote
Old 06-07-2016, 11:54 AM   #3
Senior Member
 
Join Date: Apr 2016
Location: Cedar Creek Lake, TX
Posts: 1,229
Thanks I will give that a try. Unit doesn't run long enough to freeze, or rest long enough to thaw, so it is baffling.
__________________
CedarCreekWoody is offline   Reply With Quote
Old 06-07-2016, 12:01 PM   #4
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 4,322
What you're describing sounds a lot like a thermostat problem.

Since it's a 2016 model, I assume it has the digital thermostat. There have been some problems with that t-stat and control board.

Those units stop the fan when switching between high and low or low and high and it sounds like yours may be doing that prematurely.
__________________
Salem 29RKSS Pushing a GMC Sierra 2500HD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 06-07-2016, 05:47 PM   #5
Senior Member
 
Join Date: Apr 2016
Location: Cedar Creek Lake, TX
Posts: 1,229
Quote:
Originally Posted by Bama Rambler View Post
What you're describing sounds a lot like a thermostat problem.

Since it's a 2016 model, I assume it has the digital thermostat. There have been some problems with that t-stat and control board.

Those units stop the fan when switching between high and low or low and high and it sounds like yours may be doing that prematurely.
I think you may be right. Perhaps I should call the factory. I assume it takes a special thermostat due to the two speed fan and auto operation.
Thanks for the info.
__________________
Cedar Creek Lake, Texas
2017 Wildwood 27 RLSS
2016 Ram 5.7L crewcab, 8 speed transmission
CedarCreekWoody is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:43 PM.