Reply
 
Thread Tools Display Modes
Old 05-24-2015, 07:35 AM   #1
Junior Member
 
Join Date: Nov 2014
Posts: 20
AC Issue

Took our SunSeeker 2300/2010 out this weekend. We had the AC run for about four hours in the afternoon. We shut the unit off at about 2000 from the control panel. About 10 minutes after it shut down it powered back on. The whole unit did not start but it sounded like the blower at the AC unit started. There was no cold air coming out of the vents...the unit just started for about 5 minutes and then shut off. The unit would stay quiet for about 20 minutes then it would kick back on....just sounds like the blow but no cold air. This went on all night until power was disconnected. Plugged the RV in this morning and again the AC unit would start then shut off and then repeat. Any ideas on what is wrong and how to stop the unit from "running"...blower/motor or something else? Thanks
__________________

__________________
stachowski8482 is offline   Reply With Quote
Old 05-24-2015, 04:01 PM   #2
KCM
Junior Member
 
Join Date: May 2015
Location: Oklahoma
Posts: 7
It sounds like you have lost a start capacitor or possibly the compressor. The blower will start for just a bit before the compressor kicks in. If the compressor fails to start the system will time out and shut down. The sequence will continue to repeat itself until shut off at the thermostat or obviously the power is unhooked. Sounds like a trip to someone who knows RV air conditioners is in order. Just a tip from a bad experience, make sure they know RV units as they are somewhat different than home or automotive.
__________________

__________________
2016 Sandpiper 380BH5
2011 Ram 2500 4X4 MC Cummins
KCM is offline   Reply With Quote
Old 05-24-2015, 04:59 PM   #3
Junior Member
 
Join Date: Nov 2014
Posts: 20
My original thought was the compressor. However, the AC will start and run and produce cold air when I turn it on from the thermostat. It is when I shut it off from the thermostat. The air will stop but the unit/fan will keep running. It will eventually shut off but will kick on for a few minutes then shut off
__________________
stachowski8482 is offline   Reply With Quote
Old 05-24-2015, 05:08 PM   #4
Senior Member
 
Join Date: Feb 2015
Posts: 594
Most likely a bad fan cycle switch.
__________________
2016 Flagstaff 23lb
Toddupton is offline   Reply With Quote
Old 05-24-2015, 06:09 PM   #5
Senior Member
 
67cudafb's Avatar
 
Join Date: Dec 2014
Location: N FLA
Posts: 138
Is the stat flashing any codes?
__________________
1967 Barracuda fastback
2015 Wildcat MK 333
2010 Ram 2500 Mega-cab
67cudafb is offline   Reply With Quote
Old 05-24-2015, 06:49 PM   #6
Junior Member
 
Join Date: Nov 2014
Posts: 20
ac

Where would I find any status codes? There are no codes on the thermostat... Do not believe it is the compressor.. Can still turn on ac and it blow cold air..fan or whatever kicks on is still annoying..guess I will b making an appt
__________________
stachowski8482 is offline   Reply With Quote
Old 05-24-2015, 07:21 PM   #7
KCM
Junior Member
 
Join Date: May 2015
Location: Oklahoma
Posts: 7
I'm with Todd. Fan switch or thermostat if it will work but still cycle the fan when you ask it to turn off.
__________________

__________________
2016 Sandpiper 380BH5
2011 Ram 2500 4X4 MC Cummins
KCM is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:21 AM.