Reply
 
Thread Tools Display Modes
Old 05-24-2014, 05:33 PM   #1
Member
 
Join Date: Apr 2014
Posts: 48
Advent microwave problem

Hi. I just bought a 2013 vibe 6504 from a private party. All good but the advent microwave. It is dual microwave and convection. It has power. I can choose power and start it on microwave. And select convection. The fan starts. Bit nothing is heated. On microwave or convection. Amy ideas? Is there a separate fuse?
__________________

__________________
ptownvibe is offline   Reply With Quote
Old 05-24-2014, 06:30 PM   #2
Denver, CO
 
garbonz's Avatar
 
Join Date: Jan 2013
Location: Denver, CO
Posts: 1,905
Nope. They are cheap and break. Nothing to fix. Just replace it.
__________________

__________________
2007 Chevy 2500HD Classic LBZ Duramax/Allison (Stock)
2005 Bigfoot 1500C8.2 AWESOME
garbonz is offline   Reply With Quote
Old 05-26-2014, 03:26 PM   #3
Member
 
Join Date: Apr 2014
Posts: 48
Just pull the six screws, remove the grill and pull out? Is it plugged in or hard wired?
__________________
ptownvibe is offline   Reply With Quote
Old 05-28-2014, 10:54 PM   #4
Member
 
Join Date: Apr 2014
Posts: 48
I called Advent. They pretty much said if it doesn't heat it's shot. 1.5 years old so out of warranty. Very nice.
__________________
ptownvibe is offline   Reply With Quote
Reply

Tags
vent

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:06 AM.