Reply
 
Thread Tools Display Modes
Old 10-13-2014, 10:21 PM   #1
Junior Member
 
Join Date: Apr 2013
Posts: 3
Backup Camera issues

hello all !!! We have a 2008 Georgetown 340TS went to head out camping over the weekend. Started RV and heard a click. Backup camera and radio went off. Radio works if I put in accessory mode but not with key on. Backup camera will not go on at all even in reverse. Any ideas ??
__________________

__________________
Jdmacdaddy is offline   Reply With Quote
Old 10-24-2014, 05:53 PM   #2
Member
 
Join Date: Aug 2007
Posts: 49
Sounds to me like you need to check your fuses. My Georgetown is a little older than yours (2004) so I'm not sure where yours are located, but on mine, there is a Ford chassis fuse box on the firewall on the driver's side to the left of and below the steering column in the coach that would have fuses for those accessories. If you have a similar box, check your Ford owner's manual for those fuse locations and then test the ones that seem the most likely culprits to see if one has blown. Hopefully you will find one.
__________________
BigMac8253 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:11 AM.