Reply
 
Thread Tools Display Modes
Old 11-11-2007, 05:10 PM   #21
Junior Member
 
Join Date: Oct 2007
Posts: 10
Have talked to Jeff Richardson at FR and they are aware the ZX600 is a pig...and I am having my first replaced under warranty after 2 outings. The DVD player died the second time out....and the surround speakers have a great deal of decoder noise that I believe is the result of a faulty 5.1 Dolby circuit. The A and B speakers do not have the noise. I did rewire the speaker, power and signal cables....it is a major mess behind the unit from the factory....a LOT of excess cables that can only lead to more issues.
__________________

__________________
jwcgc29 is offline   Reply With Quote
Old 11-28-2007, 11:11 AM   #22
Senior Member
 
amxpress's Avatar
 
Join Date: Nov 2007
Location: Clayton, NC
Posts: 683
I've got the model 500 in my 2007 Sabre. DVD sometimes won't work, volume with a DVD is LOUD, even on level 1. It feels like a cheap unit. I spoke to my dealer and he told me to remove it, bring it in, and he'll get me a new one. If it breaks again, I'm going with a home DVD/AM/FM setup. I like the 12V operation, but I haven't been able to find one. Anyone have an idea where to get a quality 12V unit?
__________________

__________________
2013 Palomino Columbus 320RS
2007 Dodge RAM 2500 6.7 Cummins
Reese 15K manual slider
Prodigy
M.I.L. in Florida for good!!
amxpress is offline   Reply With Quote
Old 11-28-2007, 05:01 PM   #23
Junior Member
 
Join Date: May 2007
Location: Michigan
Posts: 1
Thumbs up Replacement unit...

I posted a comment several months ago about my concertone CD/DVD player not working.. I was asked to update the thread with the outcome of dealing with the waranty. Well.... I am recieving an "upgraded" model to replace the POS I sent in.. Since I am in northern MI and its a TAD brisk, I will wait until spring to install it. Hopefully it is a better product than the first one. I have to give some "props" to Burnside RV in Houghton Lake. MI, they were very helpful and pleasant to work with. Happy Camping all !
__________________
peva4me is offline   Reply With Quote
Old 11-28-2007, 06:46 PM   #24
Senior Member
 
powerboatr's Avatar
 
Join Date: Aug 2006
Location: homebase Quitman Texas at Lake Fork
Posts: 1,388
Quote:
Originally Posted by amxpress View Post
I've got the model 500 in my 2007 Sabre. DVD sometimes won't work, volume with a DVD is LOUD, even on level 1. It feels like a cheap unit. I spoke to my dealer and he told me to remove it, bring it in, and he'll get me a new one. If it breaks again, I'm going with a home DVD/AM/FM setup. I like the 12V operation, but I haven't been able to find one. Anyone have an idea where to get a quality 12V unit?
this is funny
my volume just doesnt seem loud enough,
even at 40 setting?
if anyone finds a suitable 12volt replacement model PLEASE SHARE

now to get the hdtv plasma tv to work on 12volts ?????
__________________
Living in the Piney Woods of Texas.
powerboatr is offline   Reply With Quote
Old 11-29-2007, 04:33 AM   #25
Senior Member
 
Young Travelers's Avatar
 
Join Date: Aug 2007
Location: Lakeview Oregon
Posts: 134
QUOTE::now to get the hdtv plasma tv to work on 12volts ?????

easy, put in a power inverter, 1100-1500 watt should work, it runs off the batts, and is easy to plug in which ever AC power usng accessory. U can get one from $55-200 depending on where U shop.
we use it for the tv and PS2 when camping and cant use the genset due to noise and trying to be kind to close neighbors....(dry camping)
the only noise from the inverter is its little fan running and a beep when the battery gets low from use...
__________________
YT
2007 Dodge 2500 QC 4x4 LB CTD
2004 Forest River Salem 39FBRB
2005 Kawasaki 700 4x4 ATV
2002 Kawasaki 300 4x4 ATV
2008 Chinese 110CC kids atv


4 Great Kids......
and a wonderful wife of 12 yrs now.....
Could not ask for more
Young Travelers is offline   Reply With Quote
Old 04-09-2008, 10:00 PM   #26
Junior Member
 
Join Date: Apr 2008
Posts: 3
Apparently everyone is having the same problem with the factory installed Concertone Stereos. You would think that Forest River would seriously address the problem. My first one lost the LED lighting and the replacement had a mind of its own, turning off and on by itself then completely going KAPUT. I guess their solution is to keep replaceing them until your warranty runs out then your stuck finding a QUALITY replacement with compatible plugs. Good luck to all
__________________
campnut is offline   Reply With Quote
Old 04-19-2008, 09:53 PM   #27
Member
 
cmprguy's Avatar
 
Join Date: Oct 2007
Location: Connecticut
Posts: 86
Soooooo... a couple of weeks ago replacement #1 came in and was installed by the dealer. I got it home and everything was great!! Today we moved the trailer to it new home for the season and once we move to the inside to start settin up..I went to turn on the tunes. Guess what.. It wouldn`t turn on!! I was so angry (to be nice) at that thing. After a couple of smokes.. the wife and I pulled it out and turns out it was just a loose power wire!! No biggie..

Joel
__________________
cmprguy is offline   Reply With Quote
Old 04-20-2008, 10:50 AM   #28
Senior Member
 
Rockinwood's Avatar
 
Join Date: Oct 2007
Location: Central California
Posts: 277
Quote:
Originally Posted by cmprguy View Post
Soooooo... a couple of weeks ago replacement #1 came in and was installed by the dealer. I got it home and everything was great!! Today we moved the trailer to it new home for the season and once we move to the inside to start settin up..I went to turn on the tunes. Guess what.. It wouldn`t turn on!! I was so angry (to be nice) at that thing. After a couple of smokes.. the wife and I pulled it out and turns out it was just a loose power wire!! No biggie..

Joel
Well, at least the stereo didnt smoke!!! I am glad you found the problem.
__________________
2007 Rockwood 8317ss Reese Dual cam sway, 2002 Ford Excursion XLT V10,Prodigy Brake controller
Married DW 03/15/97 3 kids
Rockinwood is offline   Reply With Quote
Old 05-01-2008, 09:21 AM   #29
07 flagstaff
 
trek7's Avatar
 
Join Date: May 2008
Posts: 4
I bought a new 07 and have had 4 replacments so far the first 1 the dealler did 4 times the dvd player stoped workking .now the b and c speaker selection buttons stoped working.i have lokked for a replacment but cant find 1 with surround. thinkking about agood converter and switching to a home system.the dealler keeps telling me they never have problems with them .im not buying that.does any body know who makes concertone,or were there made.googgle cant even find theme
__________________
trek7 is offline   Reply With Quote
Old 05-01-2008, 12:10 PM   #30
Senior Member
 
Join Date: Mar 2008
Location: Edison, NJ, Stroudsburg, PA
Posts: 117
Send a message via Yahoo to SSport
Well, my has some problems, but not many.

I've got a question for everyone:

Is there a setting where you can listen to surround sound speakers while watching regular TV?

Also, the main problem I'm having with mine:

The ALARM goes off the same time EVERYDAY!!! Even when you hit off, it WILL come back on the next day at the same time. The book doesn't even list a way to permanently turn it off. Any suggestions?
__________________

__________________
SSport is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:09 PM.